Comfort Home Automation/ Security System Forums Home
Home Search search Menu menu Not logged in - Login | Register
Comfort Home Automation/ Security System Forums > Support > Questions on Programming Comfort > Hoping for some inspiration from someone with a good memory

Hoping for some inspiration from someone with a good memory
 Moderated by: slychiu
 New Topic   Reply   Printer Friendly 
 Rate Topic 
AuthorPost
 Posted: Friday Dec 17th, 2021 04:37 pm
   PM  Quote  Reply 
1st Post
NickLocke
Member
 

Joined: Monday Jun 15th, 2015
Location:  
Posts: 9
Status: 
Offline

  back to top

I am still running V1 (I know, but it's not broken and getting an upgrade in the UK was tricky).  I have just used DS Manager to change the IP Address of my Ethernet UCM as I have just changed to FTTP (which, by the way, is very nice!).  I did poke most of the buttons on the Ethernet UCM before I got it to talk to DS Manager.
Unfortunately, since then, it seems that contact with the CBUS UCM has been lost - there is no comms between Comfort and CBUS.  To try and resolve that I reloaded the latest CCL file (using Comfigurator 2.2.3), with no difference.
I have tried resetting the CBUS UCM and, again, no difference.
So, basically, I am looking for some inspiration on what to try next.
Here's hoping!
Thanks,
Nick

Last edited on Friday Dec 17th, 2021 04:37 pm by NickLocke



 Posted: Friday Dec 17th, 2021 05:37 pm
   PM  Quote  Reply 
2nd Post
Home
Comfort Distributors
 

Joined: Wednesday Jul 12th, 2006
Location: United Kingdom
Posts: 771
Status: 
Offline

  back to top

So you have connection to Comfort via the Ethernet UCM OK !
Are you then able to scan the Comfort network using Configurator ?
If so does the ethernet UCM and the UCM CBUS appear in the modules tab?

If it does not appear its not on the Comfort bus - but Comfort will probably be giving an error UCM 2 ?



 Posted: Friday Dec 17th, 2021 06:51 pm
   PM  Quote  Reply 
3rd Post
NickLocke
Member
 

Joined: Monday Jun 15th, 2015
Location:  
Posts: 9
Status: 
Offline

  back to top

Home wrote: So you have connection to Comfort via the Ethernet UCM OK !
Are you then able to scan the Comfort network using Configurator ?
If so does the ethernet UCM and the UCM CBUS appear in the modules tab?

If it does not appear its not on the Comfort bus - but Comfort will probably be giving an error UCM 2 ?


Thanks for the prompt response.  
Yes, I can connect via the Ethernet UCM, which is a good start.
I have been using Comfigurator 2.2.3 which, I don't think supports scanning.  
I just tried version 3.10.4.0 and, surprisingly, it managed to managed to read the configuration from Comfort. A little odd though - I didn't open a CCL file first, I just started Comfigurator and then did a Transfer / Read from PC to Comfort.  Once it finished, many of the entries (Zones/Inputs for example) had names showing in Comfigurator - no idea where they came from!  I did the whole thing again, just to double check - they were definitely not there before I did the read!
Similarly, it has picked up that there are two UCMs - one general and one CBUS.  I think that has come from the same mysterious source as the zone names though.  The Modules tab is not showing any UCMs - unsurprisingly, I guess as the firmware is too old to allow scanning.
I've seen the "finding the names" thing happen before - yet my understanding is that the names are not stored inside Comfort, so it must be picking up a config file from somewhere without being asked, I think!
Not sure where to go from here.  I can only guess that my poking around on the Ethernet UCM buttons, before I worked out which one was the reset, has screwed something up, causing the CBUS UCM to be hidden.
Thanks again for the help - and fingers crossed.
Nick 



 Posted: Saturday Dec 18th, 2021 01:50 am
   PM  Quote  Reply 
4th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 5202
Status: 
Offline

  back to top

When you read from Comfort, the zone names could be automatically generated if the zone types are not null



 Posted: Saturday Dec 18th, 2021 09:18 am
   PM  Quote  Reply 
5th Post
NickLocke
Member
 

Joined: Monday Jun 15th, 2015
Location:  
Posts: 9
Status: 
Offline

  back to top

Thanks Chiu.  I have just tried another upload to double check - the names mostly seem to be very accurate.  Has it perhaps worked out the Zone Names from the Phrases?  Something isn't quite right with the vocabulary though - we don't have a "Maid" or "Children".  I have attached an "after" image.

Something else I have noticed this morning.  Comfort announced that it was opening the curtains.  The action immediately after that should be that it opens a blind - triggered by a pulse of channel 25 which is on a LEM in the expansion cabinet .  What actually happened was that a light was switched on - which can only have happened via the CBUS UCM.
I don't know whether that gives any more clues, but it sounds like that there is some kind of mismatch between the hardware and the programming.
I also noticed while looking around in Comfigurator (remember 2.2.3) that where we had a phase of "all" and "rooms" in the Control Menu, it now has "" and "room" - again suggesting a vocabulary issue.  I wonder whether the Comfigurator version which I used years ago, but lost and replaced with one downloaded a few months back, had an updated vocabulary or something.
Any more clues very welcome.
Thanks,
Nick

Attachment: After.PNG (Downloaded 13 times)



 Posted: Sunday Dec 19th, 2021 02:49 am
   PM  Quote  Reply 
6th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 5202
Status: 
Offline

  back to top

Comfigurator does generate the zone names from the 4 zone wordsHowver there may be a mismatch between the vocabulary and your comfiguratir settings.

I suggest you check your ccl file and write to Comfort so everything is synchronised.as waht you rtead by Comfigurator may not be correct for Comforrt 1
The best option would be to upgrade your Comfort. Why was iyt tricky to het an upgrade?



 Posted: Sunday Dec 19th, 2021 09:31 am
   PM  Quote  Reply 
7th Post
NickLocke
Member
 

Joined: Monday Jun 15th, 2015
Location:  
Posts: 9
Status: 
Offline

  back to top

Hi Chiu, thanks.

It was a long while ago, when there wasn't really any partner/supplier available in the UK. I should look again :-)  Recommendations welcome.....

Meanwhile, I think I am going back to basics. I have realised that I have loads of stuff configured which isn't used any more (an IR receiver for example). I think I will "start again" programming just the security stuff and then build up again gradually.

I have spent the morning on that journey - and everything that I have tried so far is working fine.  :-)

Last edited on Sunday Dec 19th, 2021 01:20 pm by NickLocke



 Posted: Monday Dec 20th, 2021 01:37 am
   PM  Quote  Reply 
8th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 5202
Status: 
Offline

  back to top

It is a good idea to  sytart from basics
Check out laser.com
They have stock and can provide support.
If you get the new CM9001, you can add the wifi01 or ETH03 plug in submodule, or add UCM/GSM, IRIO and get the benefit of many new features that have bneen added to firmware



 Current time is 01:06 pm
Comfort Home Automation/ Security System Forums > Support > Questions on Programming Comfort > Hoping for some inspiration from someone with a good memory
Top




UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems