Comfort Home Automation/ Security System Forums Home
Home Search search Menu menu Not logged in - Login | Register

iPAD application - Configuration loading problem
 Moderated by: ident, hendy
 New Topic   Reply   Printer Friendly 
 Rate Topic 
AuthorPost
 Posted: Saturday Apr 27th, 2013 10:02 am
   PM  Quote  Reply 
1st Post
agenor
Comfort Installers


Joined: Thursday Apr 21st, 2011
Location: Rijeka, Croatia
Posts: 86
Status: 
Offline

  back to top

We are having problems with the iPAD application. We have uploaded succesfully
the .cclx file to the Cytech server. When we tap on the .jcrlccip file that we received
by mail (gmail), after selecting the "Open in ComfortiPAD" button and after selecting
one of the configurations in the iPAD application (Home, Office) the iPAD application
closes. We even tried this process with a new (blank) file, but with no success.
Are we doing something wrong?



 Posted: Saturday Apr 27th, 2013 10:17 am
   PM  Quote  Reply 
2nd Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3493
Status: 
Offline

  back to top

Can you send the cclx file to support@cytech.biz to check

If you do not tap on the attachment, can you enter the IP address of the comfort and connect  to the Comfort system although you cannot see the zones and Controls menu? You should be able to arm and disarm



 Posted: Saturday Apr 27th, 2013 11:29 am
   PM  Quote  Reply 
3rd Post
agenor
Comfort Installers


Joined: Thursday Apr 21st, 2011
Location: Rijeka, Croatia
Posts: 86
Status: 
Offline

  back to top

We have send to file to support@cytech.biz.

Yes, we can connect to the Comfort system when simply entering the IP address,
but we than can not see the zones and control menu.



 Posted: Sunday Apr 28th, 2013 03:52 am
   PM  Quote  Reply 
4th Post
Calistra
Member
 

Joined: Thursday Sep 8th, 2011
Location:  
Posts: 9
Status: 
Offline

  back to top

The cclx created by latest version of comfigurator includes all the access addresses for your system and these are automatically added to your configuration files in the iPad App.

We had overlookedwhat would happen if these values were not supplied (due to you having an older cclx file). It causes the import to crash - hence the Zones not being seen.

This has been fixed in the convertor and also in an update to the App that will be released in future.

Please resubmit your cclx file for conversion and everything should work as expected.



 Posted: Sunday Apr 28th, 2013 05:58 am
   PM  Quote  Reply 
5th Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3493
Status: 
Offline

  back to top

One of the useful features in Comfigurator 3.6 is the ability to save Local and Internet IP addresses so you do not have to remember the IP addresses when you are in the house and away from the house
You can just select Local or Internet connection fron the UCM Connections drop down box as shown below



 Posted: Monday Apr 29th, 2013 07:48 am
   PM  Quote  Reply 
6th Post
agenor
Comfort Installers


Joined: Thursday Apr 21st, 2011
Location: Rijeka, Croatia
Posts: 86
Status: 
Offline

  back to top

Thank you! The upload works fine now.

I have another question regarding the iPAD application.
The Home Control/Home Control Appliance tab (centre pane) does not show any
status information, although the instruction manual of the iPAD application clearly shows that the statuses for all the appliances are displayed in the centre pane.
Are we doing something wrong?



 Posted: Monday Apr 29th, 2013 08:55 am
   PM  Quote  Reply 
7th Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3493
Status: 
Offline

  back to top

In the A1.cclx file that you sent to support@cytech.biz, you do not have any Home control menu defined The Home control menu is blank
You need the Home control menu to have control and status
-



 Posted: Monday Apr 29th, 2013 09:27 am
   PM  Quote  Reply 
8th Post
agenor
Comfort Installers


Joined: Thursday Apr 21st, 2011
Location: Rijeka, Croatia
Posts: 86
Status: 
Offline

  back to top

Yes, i have done that. Still, the status information on the
Home Control menu in the iPAD application is not visible.
I will send you the new .cclx file A1v5 to support@cytech.biz.



 Posted: Monday Apr 29th, 2013 12:39 pm
   PM  Quote  Reply 
9th Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3493
Status: 
Offline

  back to top

You must understand that to see status you must specify in Control Menu what type of  status is needed


As you can see from the screenshot above, your Feedback Type is NONE, thus there is no status. You must select status type as Output, Input, Counter, sensor and depending on the feedback type, the associated zone, output, counter, sensor number for the status

Since the control menu Garage Light is controlling KNX, you can use the counter mapped to the KNX group address for Feedback
Then Comfort will know what status to provide

Please refer to the UCM/KNX Manual and the Comfigurator reference manual as these give full instructions

KNX Manual http://www.cytech.biz/ucmknx_manual.html

Programming with Comfiguraror http://www.cytech.biz/programming_with_comfigurator.html







 Posted: Monday Apr 29th, 2013 07:21 pm
   PM  Quote  Reply 
10th Post
agenor
Comfort Installers


Joined: Thursday Apr 21st, 2011
Location: Rijeka, Croatia
Posts: 86
Status: 
Offline

  back to top

OK. Thank you very much for your help! I missed that one. I will try that.

I also tried to bypass a zone with the iPAD app, but with no success. I tried to
bypass the open zone by selecting it, then clicking on the BYPASS button. Am i
doing this right? The zone bypass with the keypad (KP04) works.

The bypass alarm type is enabled.
Am i missing something?



 Posted: Tuesday Apr 30th, 2013 06:01 am
   PM  Quote  Reply 
11th Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3493
Status: 
Offline

  back to top

The Bypass symbol is not for bypassing indiividual zones
It is for Force arming

If you try to arm the system but there are open zones they are shown on the app
Pressing the "Bypas" icon will automatically byypass alll open zones and arm the system
This is a better wway than bypassing individual zones



 Posted: Tuesday Apr 30th, 2013 06:51 am
   PM  Quote  Reply 
12th Post
agenor
Comfort Installers


Joined: Thursday Apr 21st, 2011
Location: Rijeka, Croatia
Posts: 86
Status: 
Offline

  back to top

I have tried that, but nothing happens. I even tried holding the BYPASS button
longer, but with no success.
The "Allow Force Arm" parameter in the Modules and Settings tab is checked.



 Posted: Tuesday Apr 30th, 2013 06:54 am
   PM  Quote  Reply 
13th Post
agenor
Comfort Installers


Joined: Thursday Apr 21st, 2011
Location: Rijeka, Croatia
Posts: 86
Status: 
Offline

  back to top

I'm sorry. The bypass works fine. I was doing it wrong.
Thank you.



 Posted: Tuesday Apr 30th, 2013 01:34 pm
   PM  Quote  Reply 
14th Post
agenor
Comfort Installers


Joined: Thursday Apr 21st, 2011
Location: Rijeka, Croatia
Posts: 86
Status: 
Offline

  back to top

One more thing regarding Home Control Menu on iPAD.

I have tried the feedback types Counter, Flag and Output, but the
status on the iPAD does not update after an On or Off command. Only
when i kill the iPAD app and restart it the status is updated.



 Posted: Tuesday Apr 30th, 2013 01:43 pm
   PM  Quote  Reply 
15th Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3493
Status: 
Offline

  back to top

The on or off command must correspond to the feedback status that you specify
Ie if status is output then your on and off command must be controlling the same output



 Posted: Tuesday Apr 30th, 2013 01:52 pm
   PM  Quote  Reply 
16th Post
agenor
Comfort Installers


Joined: Thursday Apr 21st, 2011
Location: Rijeka, Croatia
Posts: 86
Status: 
Offline

  back to top

Yes, i have done that. For example, the current On and Off commands are
controlling Output 6 (a relay is connected to output 6 so i can see it turn on and
off).  I selected Feedback Type  Output and Feedback Name Output 6.
Only when i kill the iPAD app and restart it, the real status is shown.



 Posted: Thursday May 2nd, 2013 07:48 am
   PM  Quote  Reply 
17th Post
hendy
Cytech


Joined: Wednesday Sep 19th, 2007
Location: Singapore
Posts: 221
Status: 
Offline

  back to top

The A1v5.cclx file that you sent to support indicates that the Comfort firmware you are using is the older ULT 6.028.
Also the Comfigurator software is of version 3.4.4.

Please upgrade both the Comfigurator software and ULT firmware to the latest version.
In the newer Comfigurator software v3.6.4 and above there are many new improvements and features, including "Check for Firmware Updates" function that check if there is new firmware release available from our website.
Please see: http://www.comfortforums.com/forum20/3261.html

I do encounter status updating issue in ULT 6.028; but not in the latest firmware ULT 7.027.

So please upgrade and let us know the result.



 Posted: Thursday May 2nd, 2013 11:24 am
   PM  Quote  Reply 
18th Post
agenor
Comfort Installers


Joined: Thursday Apr 21st, 2011
Location: Rijeka, Croatia
Posts: 86
Status: 
Offline

  back to top

I have upgraded the Comfort controller firmware to 7.027 version and installed the new Comfigurator SW (3.6.8). I have created a test project. With the Home Control menu i am turning the output 6 On and Off. The feedback parameters are as follows:

Feedback type = Output
Feedback Name = Output 6

The status of the output 6 is not shown, instead only a waiting symbol is shown, i.e.
a clock with the text "waiting" beside it. Am i missing something?

I also tried the F-2 function on the keypad and it works fine, the keypad announces the correct current state of the output 6.



 Posted: Friday May 3rd, 2013 12:12 am
   PM  Quote  Reply 
19th Post
hendy
Cytech


Joined: Wednesday Sep 19th, 2007
Location: Singapore
Posts: 221
Status: 
Offline

  back to top

Hmm... Perhaps the UCM/ETH02 firmware?
Please upgrade to the latest version as well.



 Posted: Friday May 3rd, 2013 10:24 am
   PM  Quote  Reply 
20th Post
agenor
Comfort Installers


Joined: Thursday Apr 21st, 2011
Location: Rijeka, Croatia
Posts: 86
Status: 
Offline

  back to top

Yes, the firmware upgrade fixed the problem. It works fine now.
Thank you for your help!



 Current time is 09:54 am
Top




UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems