Comfort Home Automation/ Security System Forums Home
Home Search search Menu menu Not logged in - Login | Register

Cannot get Iphone App to work
 Moderated by: admin
 New Topic   Reply   Printer Friendly 
 Rate Topic 
AuthorPost
 Posted: Friday Jan 25th, 2013 08:26 pm
   PM  Quote  Reply 
1st Post
ComfortGeek
Member


Joined: Thursday Jul 12th, 2012
Location:  
Posts: 66
Status: 
Offline

  back to top

I've just bought and installed the ETH02 specifically so that I can use the Iphone App, but it doesn't work! The App says connected on the front page of the App, but when I input my code and press send, nothing happens. Neither can I get Comfigurator to speak to comfort via the ETH02.

I'm comfortable I have inputted the right IP address and port into the App, and set it up correctly in DS manager, as it says "connected" on the Iphone app. When I change the port or IP address to a random number, it says data error.

So, could it not work because:
- The ETH02 firmware is not good enough (I've only just got it so surely it has up to date firmware)?
- Could the UCM06 baseboard need it's firmware upgrading? If so, can I use the UCM/CBus to do this?
- I've plugged the ETH02 on to the 232 daughterboard, which is connected to the UCM06 - could that be the issue? Should I remove the 232 daughterboard? I did not change anything in modules and settings - should I have done so?
- Comfort is firmware version 6.022
- The Ethernet port on ETH02 is connected to a hub, which is connected to the wireless router/modem, which is connected to the internet
- I have no problem connecting to comfigurator via the wireless router and CWM, but cannot connect comfigurator to comfort via ETH02

Any idea why the iphone App isn't working? I've tried everything apart from upgrading firmware, but cannot work out how to upgrade UCM06.....



 Posted: Friday Jan 25th, 2013 09:49 pm
   PM  Quote  Reply 
2nd Post
wexfordman
UCM Pi Users
 

Joined: Monday Jan 1st, 2007
Location: Cork, Ireland
Posts: 534
Status: 
Offline

  back to top

Forget the app for the moment, and just concentrate on connecting via comfigurator to the eth02.

How was comfigurator connecting to comfort before you got the eth02, have you set up a new ucm I'd for the eth02, and configured it in comfort?

Have you checked the led status of your new eth board and are they lighting incorrect sequence?



 Posted: Saturday Jan 26th, 2013 01:32 am
   PM  Quote  Reply 
3rd Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3493
Status: 
Offline

  back to top

Do you mean you plugged the ETH02 submodule on top of the Rs232 submodule

That causes both RS232 and ETH02 to stop working. Only one interface can be connected

You can upgrade UCM firmware very easily using Comfigurator 3.6.4
Right click on the UCM in Modules Tab and select "Check for Updates"
see http://www.comfortforums.com/view_topic.php?id=3261&forum_id=20



 Posted: Sunday Jan 27th, 2013 06:16 pm
   PM  Quote  Reply 
4th Post
ComfortGeek
Member


Joined: Thursday Jul 12th, 2012
Location:  
Posts: 66
Status: 
Offline

  back to top

I've disconected the 232 and it now works, Eureka! Thanks so much!

I had the AUD01 module on the 232 - is there anywhere else I can connect this as I dont seem to be able to connect that to the ETH02?



 Posted: Sunday Jan 27th, 2013 07:07 pm
   PM  Quote  Reply 
5th Post
ComfortGeek
Member


Joined: Thursday Jul 12th, 2012
Location:  
Posts: 66
Status: 
Offline

  back to top

The issue is now have is the control menu does not work. I can connect to confort via the iphobe App, arm & disarm comfort, but I cannot get the lighting to show it's status or operate from the i-phone app. i.e. when I click on the on round button for the hall light, nothin happens (I can see the lights on the UCM flashing differently, so it looks like info is coming through, just not doing anything)

Reading the posts here, I think the issue might be the firmware on the UCM/ETH02?

I bought the ETH02 very recently and have plugged it into the UCM baseboard I bought a few years back in 2010.

I have a UCM CBus and the 232 daughterboard - can I use rither of these to upgrage the firmware on the UCM/ETH02?
Comfigurator says it's UCM 5.212 and comfort is 6.022



 Posted: Monday Jan 28th, 2013 02:19 am
   PM  Quote  Reply 
6th Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3493
Status: 
Offline

  back to top

The iphone app has a minimum required firmware for Comfort 6.004 and UCM 6.002
see http://www.comfortforums.com/forum96/2372.html

Your UCM is version 5. You need to upgrade this to at least version 6 so that you can use this to upgrade the Comfort firmware

You need another UCM to be able to upgrade your UCM firmware using Comfigurator

I suggest you send your UCM to your Comfort supplier for upgrade, or get a friend with a UCM to upgrade it for you

By the way the latest firmware for UCM and Comfort is version 7

Once you have upgraded your comfort and UCM,  Comfigurator 3.6.4 will make it very easy to upgrade all your firmware in future
see http://www.comfortforums.com/view_topic.php?id=3261&forum_id=20



 Posted: Monday Jan 28th, 2013 06:13 am
   PM  Quote  Reply 
7th Post
ComfortGeek
Member


Joined: Thursday Jul 12th, 2012
Location:  
Posts: 66
Status: 
Offline

  back to top

Thanks! I'll get this done. Can't wait to use the iPhone App properly!

The AUD01 module that I used to plug onto the UCM232, can this connect to comfort any other way? ( I have removed the 232 to make way for ETH02).



 Posted: Monday Jan 28th, 2013 01:06 pm
   PM  Quote  Reply 
8th Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3493
Status: 
Offline

  back to top

The aud01 can be connected to the UCM/232 or ethermet or USB
The purpose is to use the PC eg Wizcomfort as a keypad so you can her the comfort voice
Hence the AUD01 can be   connected to a external speaker and mic even with the ETH02. However the voice does not go through the network



 Posted: Monday Jan 28th, 2013 07:23 pm
   PM  Quote  Reply 
9th Post
ComfortGeek
Member


Joined: Thursday Jul 12th, 2012
Location:  
Posts: 66
Status: 
Offline

  back to top

I was hoping the ADM01 would go on the ETH02 but there is no holes on the ETH02 for it to connect.

The 232 duaghterboard had holes for the PINS to go into, but the ETH02 I've just bought does not have the holes....

Have a got the wrong ETH02?



 Posted: Tuesday Jan 29th, 2013 02:11 am
   PM  Quote  Reply 
10th Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3493
Status: 
Offline

  back to top

Do you mean ADM01 or AUD01?


The new version of the AUD01 can be plugged on to the ETH02 as it has extended connectors
The older AUD01 cannot
Please send a photo of the AUD01



 Posted: Tuesday Jan 29th, 2013 02:26 am
   PM  Quote  Reply 
11th Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3493
Status: 
Offline

  back to top

My apologies
ETH02 is not able to mount the AUD01 on top at all



 Posted: Tuesday Jan 29th, 2013 08:33 pm
   PM  Quote  Reply 
12th Post
ComfortGeek
Member


Joined: Thursday Jul 12th, 2012
Location:  
Posts: 66
Status: 
Offline

  back to top

Oh no! The UCM manual says you can connect AUD01 to ETH02 which is one of thr reasons I bought the ETH02!

It would be worth taking this out of the manual.

So looks like I'll have to buy another UCM06 to connect my 232 onto, so I can have the AUD01 connected!



 Posted: Wednesday Jan 30th, 2013 10:55 am
   PM  Quote  Reply 
13th Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3493
Status: 
Offline

  back to top

Sorry about that, I will notify the technical writers to amend that ASAP



 Posted: Tuesday Jul 16th, 2013 09:08 pm
   PM  Quote  Reply 
14th Post
ruirego
Comfort Installers


Joined: Tuesday Aug 29th, 2006
Location: Ponta Delgada, Portugal
Posts: 18
Status: 
Offline

  back to top

hello,
I also have the app working with the security: zones, arm, disarm ok. the only thing that's not working is the home control. since some the security
is working I assume that the firmware of the eth02 is ok

so what could I be missing?

thanks!
Rui Rego



 Posted: Wednesday Jul 17th, 2013 02:24 am
   PM  Quote  Reply 
15th Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3493
Status: 
Offline

  back to top

The iphone app has a minimum required firmware for Comfort 6.004 and UCM 6.002


Check what is the firmware on Comfort and UCM using the Modules Scan function see http://www.comfortforums.com/forum92/3399.html

It is recommended to upgrade the Comfort and UCM/ETH02 firmware to the latest according to instructions in http://www.comfortforums.com/forum92/3400.html

Last edited on Monday Jul 22nd, 2013 12:41 pm by ident



 Posted: Monday Jul 22nd, 2013 12:14 pm
   PM  Quote  Reply 
16th Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3493
Status: 
Offline

  back to top

For troubleshooting of commonly encountered problems please see http://www.comfortforums.com/forum116/3459.html



 Current time is 01:39 am
Top




UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems