Comfort Home Automation/ Security System Forums Home
Home Search search Menu menu Not logged in - Login | Register

X10 Lockup Problem Fixed
 Moderated by: adlim
 New Topic   Reply   Printer Friendly 
 Rate Topic 
AuthorPost
 Posted: Monday Aug 7th, 2006 04:27 am
   PM  Quote  Reply 
1st Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 5132
Status: 
Offline

  back to top

Older Comfort firmware had a problem with X10 where in certain (rare) circumstances, the X10 signal stopped working, and this appeared to prevent the outputs from working as well
The outputs and X10 operation could only be resumed aftre a RESET of Comfort
This problem was very difficult to indetify as it was very dificult to duplicate. Finally we did manage to identify it with the help of a customer (thanks to Darren Rigg) and this was fixed in Firmware 4.229 released in October 2005



 Posted: Friday Nov 10th, 2006 07:48 pm
   PM  Quote  Reply 
2nd Post
Ian
Member
 

Joined: Saturday Aug 19th, 2006
Location: United Kingdom
Posts: 203
Status: 
Offline

  back to top

I use a lot of X10 - with all the usual issues!!

How do I know which firmware I have in my system?

Ian



 Posted: Saturday Nov 11th, 2006 12:38 am
   PM  Quote  Reply 
3rd Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 5132
Status: 
Offline

  back to top

3 ways;
- In Comfigurator, do Transfer > System Info
- By Keypad, go to Engineer Menu, 7,4,3
- Read the label on the U1 IC on the Comfort PCB


if you have Comfort II, you will not have to worry about the X10 lockup problem



 Posted: Saturday Nov 11th, 2006 07:56 am
   PM  Quote  Reply 
4th Post
Ian
Member
 

Joined: Saturday Aug 19th, 2006
Location: United Kingdom
Posts: 203
Status: 
Offline

  back to top

I am using Comfort 1

My firmware is 4.209

How would I upgrade? Is there a download or is it a chip change?

Ian



 Posted: Wednesday Nov 15th, 2006 01:51 pm
   PM  Quote  Reply 
5th Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3493
Status: 
Offline

  back to top

Upgrade for Comfort I requires a change in the U1 IC
This is the one with the label "Outside 4.209"



 Posted: Tuesday Mar 17th, 2009 09:32 pm
   PM  Quote  Reply 
6th Post
johnathan_dooley
Member
 

Joined: Tuesday Oct 23rd, 2007
Location: Ireland
Posts: 7
Status: 
Offline

  back to top

Hi
Can you elaborate on the specific problem that was fixed in Firmware please?.
I am having some problems, and would like to know if I'm encountering the same problems and if they will be fixed if I upgrade the firmware


Background:
I have a Comfort Gen1 with Firmware 4.222
Until recently, it controlled some marmitek micro modules and lamp plug-in modules.
I control these modules via an IR Romote using the IR Responses, triggering X10 events. It worked ok most of the time ok (which is as you'd expect from x10), and I was pretty happy with the setup.

I bought some X10-2 micro modules a couple of weeks ago (a lamp plug-in module, and 2263 dimmer module ), and its not working properly anymore.
Whenever I try to control the micro module, Comfort issues one command (eg Light On), and then hangs. If I press my remote, I dont hear the beep that signals Comfort has received an IR command, so it seems to have hung the IR responses as well as X10 output. Sometimes it sort of un-hangs and issues an old X10 command upon receiving an IR response for a new X10 command

If I reset Comfort, it usually un-hangs it.
Aletrnatively, if I wait long enough (minutes, hours sometimes) , it seems to un-hang


Regards







 Posted: Tuesday Mar 17th, 2009 10:07 pm
   PM  Quote  Reply 
7th Post
admin
Administrator


Joined: Saturday Mar 3rd, 2007
Location: Singapore
Posts: 1200
Status: 
Offline

  back to top

This was a problem for Comfort I in versions prior to 4.229. Due to received and transmitted X10 clashing in a certain way, the X10 and output signals were blocked but the rest of the system worked normally, eg you can arm and disarm the system. This was normally encountered after a period of time and is restored by a reset. However you could not get the problem just by sending one X10 command. Perhaps there was a change in the way the new X10-2 modules operate
Hence I am not sure if upgrading to Ultra I firmware 4.234 should fix the problem, but we can send you a U1 IC to test



 Posted: Wednesday Mar 18th, 2009 10:26 am
   PM  Quote  Reply 
8th Post
johnathan_dooley
Member
 

Joined: Tuesday Oct 23rd, 2007
Location: Ireland
Posts: 7
Status: 
Offline

  back to top

I should perhaps clarify that the hang happens after I send two or three IR remote commands. Not just a single command. However, at the time the hang happens, Comfort should not be receiving any simultaneous X10 commands to cause the clash you describe below. I'll check my setup to ensure this is the case.

The symptoms sound VERY similar however. Comfort is working ok (I can alarm, disarm etc) but the X10 output (and possibly the IR Receive input) hangs.

It would be great if I could get the U1 IC with new firmware to test. Can you let me know how /where to get it ?

In the meantime, I would also like to debug this a bit further. The bit I'm not sure about is whether Conmfort is receiving the commands from my IR remote, or whether its the X10 outout only that has hung.

Is there any way of logging IR Received events? For example, if I look at the Event log, I see events such as Users signing On, Alarm activated etc. But I dont see IR Received events. Is there any way to enable additional event logging?

 

Thanks



 Posted: Saturday Mar 21st, 2009 09:15 am
   PM  Quote  Reply 
9th Post
admin
Administrator


Joined: Saturday Mar 3rd, 2007
Location: Singapore
Posts: 1200
Status: 
Offline

  back to top

You need to upgrade to Ultra 1 4.234 IC01-ACT with a IC04-256 if your Comfort I is a Pro rather than Ultra.
This upgrade may not be on the distributor website but send them an email, see our UK distributors on http://www.cytech-europe.co.uk/cms/installers.php#AA

You should also consider an upgrade to Comfort II. We now have very attractive upgrade packages from Comfort I to II which may cost not much more than an upgrade to a later Comfort I firmware\

You can use the Comfigurator I/O Monitor to see received IR codes
In Comfigurator 2, go to Transfer menu and check Monitor I/O. In comfigurator 3 see http://www.comfortforums.com/forum20/1389.html (preferred), go to View and check I/O Monitor
This allows you to see received and transmitted X10 codes

X! - Transmit X10 command
PC:     X!HUUFF[RR]
UCM:    OK   
UCM:     XTHUUFF[RR]
H : House code A to P in ASCII
U:  Unit Code = 01 to 10H (16)
F : Function Code: 05= On, 07= Off, 01=All OFF, 03=All Lights ON, 09=Dim, 11=Bright, 13 = All Lights off, 15 = Extended Code 1 (Data/Control), 21 = Extended Code 3 (Security), 25 = Extended Code 2 (Meter Read)
(RR: Repeat cycles 01-08 - Applicable to Dim and Bright commands - Not implemented DA6D Do action 109 can be used to set the repeat count)
The UCM reports the transmission of the X10 code via the XT message
If UU is 0, the Unit code is not transmitted, the Housecode/Function code X10 signal is transmitted.
If FF is 0, the Housecode is not transmitted - the Housecode/Unitcode X10 signal is transmitted.
Eg
X!P1005    X10 P16 On
X!B0507    X10 B5 Off



XF - X10 house/function code Received
The UCM will reply with the XF report when  Comfort receives an X10 housecode/functioncode signal from the 2 way X10 interface
UCM: XFHff
H : House code A to P in ASCII
ff is  1 to 16  representing the function code (address),
Function Code ff: 05= On, 07= Off, 01=All On, 03=All Lights ON, 09=Dim, 11=Bright
Normally, an X10 command will have the housecode and unit code in one transmission, followed by the housecode and function code in the next transmission
Eg X10 code of "A1 ON" may be received in two messages as
UCM:    XUA01
UCM:    XFA05
The Bright and DIM commands which have no gaps in between repeated transmissions, may not be received correctly


XU - X10 House/unit code Received
The UCM will reply with the XU report when  Comfort receives an X10 housecode/unitcode signal from the 2 way X10 interface
UCM: XUHuu
H : House code A to P in ASCII
uu is  1 to 16  representing the Unit code (address),
Normally, an X10 command will have the housecode and unit code in one transmission, followed by the housecode and function code in the next transmission
Eg X10 code of "A1 ON" may be received in two messages as
UCM:    XUA01
UCM:    XFA05
The Bright and DIM commands which have no gaps in between repeated transmissions, may not be received correctly



 Posted: Monday Mar 23rd, 2009 11:31 pm
   PM  Quote  Reply 
10th Post
johnathan_dooley
Member
 

Joined: Tuesday Oct 23rd, 2007
Location: Ireland
Posts: 7
Status: 
Offline

  back to top

After it hangs, the I/O Monitor does not show any more IR codes being received.
The annoying thing is that Resetting the system does not fix it anymore.
It seems to resolve itself if I leave it alone for a few hours / overnight however.
Not an acceptable solution.

To upgrade to Comfort-II, do all the listed distributors offer the attractive upgrade package you mentioned?

Thanks




 Posted: Tuesday Mar 24th, 2009 04:08 pm
   PM  Quote  Reply 
11th Post
admin
Administrator


Joined: Saturday Mar 3rd, 2007
Location: Singapore
Posts: 1200
Status: 
Offline

  back to top

If resetting does not clear the problem then it may be due to the XM10E interface and not the firmware problem. X10 has been known to behave strangely



 Posted: Tuesday Mar 24th, 2009 04:14 pm
   PM  Quote  Reply 
12th Post
admin
Administrator


Joined: Saturday Mar 3rd, 2007
Location: Singapore
Posts: 1200
Status: 
Offline

  back to top

Yes all the distributors should offer the upgrade but not all have listed it on their websites yet

Check out http://www.smartpowershop.co.uk/department/comfort/
and http://www.cbus-shop.com/index.php?cPath=139&osCsid=9d774382bac4d03f0e1aaf79740a441f
which do offer the upgrades



 Current time is 07:39 am
Top




UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems