Comfort  Automation/ Security System Forums Home
Home Search search Menu menu Not logged in - Login | Register

Long overdue upgrade
 Moderated by: admin
 New Topic   Reply   Printer Friendly 
 Rate Topic 
AuthorPost
 Posted: Monday Oct 29th, 2012 03:49 pm
   PM  Quote  Reply 
1st Post
Majik
UCM Pi Users
 

Joined: Saturday Aug 26th, 2006
Location:  
Posts: 33
Status: 
Offline

  back to top

I have a Comfort II Ultra system which is long overdue an overhaul and upgrade. Can anyone advise me on what I need for this, and whether I have any incompatibilities with the latest firmware.

I have:

* Comfort II Ultra with v 5.115 firmware FS 34 "Week"
* UCM-ETH Type 10 running v5.159 firmware
* UCM-GSM (this is the original model)
* 3 x SEP+SEM running v4.1.5 (according to sticker)
* 3 x KP01 keypads
* 1 x KP02 keypad
* 1 x doorstation DP02 (old version)

A few things confuse me regarding what I need. In particular I'm not sure what I need for upgrading my SEP/SEMs as, according to the compatibility post http://www.comfortforums.com/forum16/1470.html my current SEP/SEMs aren't compatible with what I have.

I also understand it may be possible to upgrade the doorstation by swapping the board out with one of the newer doorstations (unfortunately it's been sunk into the brickwork so swapping it out completely probably won't be possible without leaving an ugly hole).

Any indications of what I need, ideally in the form of a kit list, and where in the UK I can go to get this list from?

Cheers,

Keith

Last edited on Monday Oct 29th, 2012 05:11 pm by Majik



 Posted: Monday Oct 29th, 2012 05:15 pm
   PM  Quote  Reply 
2nd Post
Majik
UCM Pi Users
 

Joined: Saturday Aug 26th, 2006
Location:  
Posts: 33
Status: 
Offline

  back to top

Answering my own question here after a bit more exhaustive research, it looks like I need some MPU01-SEM's for the SEPs.

If I get those and install, am I good to go with:
1. upgrading the UCM-ETH to 6.024
2. Upgrading the main comfort to 6.028
3. Upgrading the UCM-GSM to 6.015

assuming that the MPU01-SEMs have the latest firmware in already?

I believe I need another UCM (such as a Universal UCM) to do these upgrades.

Cheers,

Keith

Last edited on Monday Oct 29th, 2012 06:03 pm by Majik



 Posted: Tuesday Oct 30th, 2012 02:00 am
   PM  Quote  Reply 
3rd Post
hendy
Cytech


Joined: Wednesday Sep 19th, 2007
Location: Singapore
Posts: 221
Status: 
Offline

  back to top

MPU is a plug-in upgrade board that is used for older Comfort II version.

You mentioned that the Slaves have firmware version 4.1.5; version 4 is the older Comfort I model whose firmware is stored in an one-time programmable chip and has no provision for upgrade by a plug-in MPU board.

Slave board that can be upgraded using a MPU is shown in this post:
    http://www.comfortforums.com/forum91/2070.html

Notice there are 4 connectors surrounding the main IC?
These are for connection to the MPU.
Is your Slave board looks like the image in the post?

UCM/Eth is used to upgrade other modules but v5.159 is not able to upgrade itself, you will need another UCM/Eth or UCM/USB to upgrade it to v6.xxx.
v6.xxx can upgrade itself using the latest Comfigurator software.
See if your supplier can help with the upgrade of your UCM/Eth or if there is other user living near you that needs UCM upgrade? so the two UCMs can upgrade each other.



 Posted: Tuesday Oct 30th, 2012 09:55 am
   PM  Quote  Reply 
4th Post
Majik
UCM Pi Users
 

Joined: Saturday Aug 26th, 2006
Location:  
Posts: 33
Status: 
Offline

  back to top

I can't see those diagrams at the moment, but cytech.biz appears to be down, so I'll have a look later.

Presumably if it's the older model (which I'm pretty sure it is) I will need to purchase new SEM01-M2's.

Do I also need new LEM01-M2s? Presumably the older ones won't work with the new SEM01-M2.

Regards,

Keith



 Posted: Wednesday Oct 31st, 2012 01:35 am
   PM  Quote  Reply 
5th Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3493
Status: 
Offline

  back to top

You need to get new LEMs, see the compatibility list in the forum
http://www.comfortforums.com/forum16/1470.html



 Posted: Wednesday Oct 31st, 2012 12:09 pm
   PM  Quote  Reply 
6th Post
Majik
UCM Pi Users
 

Joined: Saturday Aug 26th, 2006
Location:  
Posts: 33
Status: 
Offline

  back to top

OK, thanks for your help. I need to get an order for this lot together now.

One question about the new SEM01-M2: it seems to have a socket for connecting an X10 interface which the old SEM01 doesn't have. Does this mean it's possible to connect the XM10E to the SEM instead of the main Comfort board?

Cheers,

Keith



 Posted: Thursday Nov 1st, 2012 04:17 am
   PM  Quote  Reply 
7th Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3493
Status: 
Offline

  back to top

Yes it should be possible to connect X10 to the Slave



 Current time is 05:40 pm
Top




UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems