Comfort Home Automation/ Security System Forums Home
Home Search search Menu menu Not logged in - Login | Register
Comfort Home Automation/ Security System Forums > Third Party (interfacing to Comfort) > Zwave > Counters mapped to Z-Wave nodes appear to be read-only ?

Counters mapped to Z-Wave nodes appear to be read-only ?
 Moderated by: slychiu
 New Topic   Reply   Printer Friendly 
 Rate Topic 
AuthorPost
 Posted: Monday Aug 10th, 2020 10:33 pm
   PM  Quote  Reply 
1st Post
muddymickey
Member
 

Joined: Monday Apr 27th, 2009
Location:  
Posts: 48
Status: 
Offline

  back to top

Hi
I have several Aeotec dimmer modules in my Z-Wave network, each of these nodes is mapped to a counter in Comfort.
If I look at the list of counters in Comfigurator, and tick "Show Status", I can see the expected values change in real time as I turn lights on/off or dim them from the wall switches.
However whenever I try and write a value to the counter, the counter status briefly changes to the requested value before reverting back to the previous state.It's as if the counters are "read only".If I try and set counter 31 to a value of 254, while the lights are switched off, I see the following messages on the UCM I/O monitor
> C!1FFE00
< OK
< CT1FFE00
> C?1F
< C?1FFE00
< CT1F0000
If I view the Z-Wave node in the "Z-Wave mapping" tab of the Z-Wave UCM, and click "Switch Device On", the lights come on.So the ability to communicate via Z-Wave is OK, it seems an issue with the counters?

The Z-Wave device is setup as such:D
DeviceID: 31
Description: Routing_Slave - Power_Switch_Multilevel
Node Type: BasicListening: Yes
Register Type: Counter
Ch1 Register Number: 31
Ch1 Register Name: Counter031
Using:Comfigurator V3.13.3.0 
Comfort II Ultra firmware 7.160
Z-Wave UCM firmware 7.102 Thanks for any help!!

Last edited on Tuesday Aug 11th, 2020 03:57 am by slychiu



 Posted: Tuesday Aug 11th, 2020 04:00 am
   PM  Quote  Reply 
2nd Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4999
Status: 
Offline

  back to top

The counters cannot be read only. The zwave device may be preventing changes to it in some way
Can you try using tge Zwave actions to sebd commands instead?



 Posted: Wednesday Aug 12th, 2020 04:48 pm
   PM  Quote  Reply 
3rd Post
muddymickey
Member
 

Joined: Monday Apr 27th, 2009
Location:  
Posts: 48
Status: 
Offline

  back to top

Thanks, using ZWave actions seems to work.

I'd been using the counter approach for some time, based on the instructions in the UCM Zwave manual, but it stopped working. I have updated Comfigurator, and the firmwares on Comfort and the Z-Wave UCM so perhaps that caused it ?

Anyway, working now, thanks for the prompt help.



 Posted: Thursday Aug 13th, 2020 03:07 am
   PM  Quote  Reply 
4th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4999
Status: 
Offline

  back to top

Thanks for the confirmation. Counters should also work for Zwave

Can you try using some other counter values besides FE?



 Current time is 09:33 pm
Comfort Home Automation/ Security System Forums > Third Party (interfacing to Comfort) > Zwave > Counters mapped to Z-Wave nodes appear to be read-only ?
Top




UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems