Comfort Home Automation/ Security System Forums Home
Home Search search Menu menu Not logged in - Login | Register

Tracking Responses sending Cbus Commands
 Moderated by: hendy
 New Topic   Reply   Printer Friendly 
 Rate Topic 
AuthorPost
 Posted: Saturday Sep 7th, 2019 07:50 pm
   PM  Quote  Reply 
1st Post
Howser
Member
 

Joined: Monday May 22nd, 2006
Location: Pretoria, South Africa
Posts: 203
Status: 
Offline

  back to top

I am using Comfigurator with Comfort 2Z Ultra (v 7.160), Cbus2 Ucm (v7.106)


 


DateTime= 2019/09/07 20:56:35.245   App= 202  Trigger Control      Group= 014  Kitchen              Unit= 008  PC_CNIEI/INL_CNI     Event= Action Selector triggered : 50, 'Motion-AutoLights OFF'

 DateTime= 2019/09/07 20:56:35.629   App= 056  Lighting             Group= 039  Kitchen Light 1      Unit= 009  PC_PACA/MOHAUPAC     Event= Group ramped to 063 ( 25%) over 12 seconds

 DateTime= 2019/09/07 20:56:35.632   App= 056  Lighting             Group= 040  Kitchen Light 2      Unit= 009  PC_PACA/MOHAUPAC     Event= Group ramped to 073 ( 29%) over 30 seconds

 DateTime= 2019/09/07 20:56:38.386   App= 056  Lighting             Group= 039  Kitchen Light 1      Unit= 127  EN_CMFT/COMFORT      Event= Group ramped to 064 ( 25%) over 0 seconds

 DateTime= 2019/09/07 20:56:38.598   App= 202  Trigger Control      Group= 014  Kitchen              Unit= 009  PC_PACA/MOHAUPAC     Event= Trigger Indicator Kill

I am using the Control Menu to send most of the On/Off commands to Cbus (mainly for using Comfort iPhone and my outgoing GSM Ucm)

I have included a log (above) from Cbus Toolkit which shows Comfort Ucm/Cbus (EN_CMFT/COMFORT) ramping Kitchen Light 1 to 25% over 0 seconds after a trigger event is raised.

I tried looking at all the responses where Kitchen Light One is referred to and for the life of me, I cannot track where in Comfort this occurs.



 Posted: Sunday Sep 8th, 2019 02:27 am
   PM  Quote  Reply 
2nd Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4663
Status: 
Offline

  back to top

Can you send the cclx file to support@cytech.biz?



 Posted: Sunday Sep 8th, 2019 07:11 am
   PM  Quote  Reply 
3rd Post
Howser
Member
 

Joined: Monday May 22nd, 2006
Location: Pretoria, South Africa
Posts: 203
Status: 
Offline

  back to top

Done, cclx file sent support@cytech.biz.



 Posted: Sunday Sep 8th, 2019 09:05 am
   PM  Quote  Reply 
4th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4663
Status: 
Offline

  back to top

I do not see any where the Counter 39 is changed by any response or otherwise
Note that changing Counter 39 value will also send the counter value to Cbus Eg if counter 39 is changed to 256/4 = 64 then that causes the Cbus deive to ramp to 25%

Turn on Monitor I/O before doing the trigger, then look for CT27 report in the monitor. This may give a clue to what caused itIt may be UCM/Pi changing the counter



 Posted: Sunday Sep 8th, 2019 02:13 pm
   PM  Quote  Reply 
5th Post
Howser
Member
 

Joined: Monday May 22nd, 2006
Location: Pretoria, South Africa
Posts: 203
Status: 
Offline

  back to top

This is what the monitor shows

< CT273F00
< CT284900
< CT279900
< CT28A500
< CT274000
< CT284A00


Last edited on Sunday Sep 8th, 2019 02:14 pm by Howser



 Posted: Monday Sep 9th, 2019 02:49 am
   PM  Quote  Reply 
6th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4663
Status: 
Offline

  back to top

< CT273F00 means the counter 39 is changed to 64That accounts for cbus lighting group address 39 going to 25%
I cant see from your responses that coumnter 39 is changed to this value. There shoukl be something else causing this. Could it be the Cbus

Go to Tools > Bus Monitor and press Start before the trigger. Then copy theBus monitor



 Posted: Monday Sep 9th, 2019 07:46 pm
   PM  Quote  Reply 
7th Post
Howser
Member
 

Joined: Monday May 22nd, 2006
Location: Pretoria, South Africa
Posts: 203
Status: 
Offline

  back to top

Find attached the bus Monitor.

Attachment: BusMonitor.txt (Downloaded 2 times)



 Posted: Tuesday Sep 10th, 2019 02:12 am
   PM  Quote  Reply 
8th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4663
Status: 
Offline

  back to top

This is the relevant message in Bus Monitpr
 21: 40: 57: 945 ----< 03 12 71 32 37 33 46 31 34 02 <--->q273F14
 21: 40: 57: 965 ----< 03 00 64 32 37 33 46 30 30 31 32 32 31 02 <--->/d273F001221


The line is red means UCM ID #2 sent Counter 39 value 3F ie 64.

Comfort broadcast the counter 39 value = 3F

Counter 37 is mapped to Lighting Group address 39. Hence when UCM/Cbus receives the message from group 39 from Cbus, it sends the Counter value  to Comfort




 Posted: Tuesday Sep 10th, 2019 06:01 am
   PM  Quote  Reply 
9th Post
Howser
Member
 

Joined: Monday May 22nd, 2006
Location: Pretoria, South Africa
Posts: 203
Status: 
Offline

  back to top

I have 
  • Cbus GA 39 (Kitchen Light 1) mapped to Counter 39 and       
  •  Cbus GA 40 (Kitchen Light 2) mapped to Counter 40.       
When the Kitchen Trigger Control is set, a cbus unit (PC_PACA) sets GA 39 to 25% over 12 seconds and GA 40 to 29% over 30 seconds. 
My question is why Comfort re broadcasting GA 39, and why only GA 39?
I thought UCM ID#2 will only update the Counter 39 and 40 in Comfort, and not broadcast their values back to Cbus?



 Posted: Tuesday Sep 10th, 2019 09:17 am
   PM  Quote  Reply 
10th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4663
Status: 
Offline

  back to top

I thought UCM ID#2 will only update the Counter 39 and 40 in Comfort, and not broadcast their values back to Cbus?

That is correct. UCM/Cbus will not send the values back to Cbus which was received from Cbus.

Go to the UCM/Cbus2 Monitor Mode. This will show the transmit and receive messages
> means transmit line, < means receive line


You can confirm here if CM/Cbus is resending to Groups 39 and 40



 Posted: Tuesday Sep 10th, 2019 10:46 am
   PM  Quote  Reply 
11th Post
Howser
Member
 

Joined: Monday May 22nd, 2006
Location: Pretoria, South Africa
Posts: 203
Status: 
Offline

  back to top

I could not get Comfigurator to connect to the UCM, even though Comfort ServerManager detected the UCM.
So I disconnected the UCM for a few seconds and connected it again.
Now I cannot reproduce the problem.
This is what I am getting from the Monitor

>all55D0000A872476s
>all55D0000A870991s
>all55D0000A860992s
>all55D0000A862477s
<0508CA00020E32E7
<050938001A273F2A28499F
>all5538000227405Al
<0509CA00090E11
>all5538000228FE9Bl
>all55380002284A4Fl
>all55D0000A872476s
>all5538000228FE9Bl
>all55D0000A870991s


The Cbus Logs no longer shows Comfort changing the GA.

Last edited on Tuesday Sep 10th, 2019 11:32 am by Howser



 Posted: Tuesday Sep 10th, 2019 12:14 pm
   PM  Quote  Reply 
12th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4663
Status: 
Offline

  back to top

Look at it again when it happens again. Com,fort should not be sending back to the same GA



 Current time is 05:00 am
Top




UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems