Comfort Home Automation/ Security System Forums Home

 Moderated by: admin  
AuthorPost
waynebr
Member


Joined: Friday May 1st, 2009
Location: United Kingdom
Posts: 89
Status: 
Offline

  back to top

Hi I am trying to connect the Z-Wave module to Samsung Smart Things but am unable to find the network. Is it possible to connect it directly or do I need a Z-wave remote control first?

slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4773
Status: 
Offline

  back to top

You need a zwave primary controller to include ucm /zwave.I do not know if smart things is a primary

Swiss-Toni
UCM Pi Users


Joined: Thursday Sep 15th, 2011
Location: Greater London, United Kingdom
Posts: 296
Status: 
Offline

  back to top

You can connect smarthings directly to Zwave

waynebr
Member


Joined: Friday May 1st, 2009
Location: United Kingdom
Posts: 89
Status: 
Offline

  back to top

Thanks I can connect smart things to z wave but the z wave ucm keeps saying not in a network. I am waiting on some z wave products so not sure if it will change when they arrive.

Swiss-Toni
UCM Pi Users


Joined: Thursday Sep 15th, 2011
Location: Greater London, United Kingdom
Posts: 296
Status: 
Offline

  back to top

Not fully up on Zwave but I dont think you can connect to both or more than one controller
!

waynebr
Member


Joined: Friday May 1st, 2009
Location: United Kingdom
Posts: 89
Status: 
Offline

  back to top

My understanding is that any  wave can have only 1 primary controller. At the moment it looks like the ucm reads the network but dosnt join it. Once my z wave devices arrive I can rule out it being an issue of not having any active z wave nodes just in case smart things turns off the network when no nodes are present. Otherwise I will wait till I can get my hands on a ucm pi.

Last edited on Wednesday Apr 17th, 2019 02:47 pm by waynebr

waynebr
Member


Joined: Friday May 1st, 2009
Location: United Kingdom
Posts: 89
Status: 
Offline

  back to top

I managed to get this to work, I had to put smarthings into inclusion mode by choosing a fibaro device and then scanning for this. It then detected virtual devices. :)

Next question what is the best way of getting it to turn the lights on/ off or dimming? I can write a response for the counter and set the counter but is there a way of sending the counter information through to CBUS without writing a load of if statements in the counter response?

slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4773
Status: 
Offline

  back to top

You can link a cbus address to zwave by making the same counter or flagFor example if the cbus address is mapped to  flag and a zwave address is mapped to the same flag then when the zwave address cinnabar state the flag will cause the cbus address to change accordinglyCounters can be make to both systems for dimmingSo there is no need to use responses at all

waynebr
Member


Joined: Friday May 1st, 2009
Location: United Kingdom
Posts: 89
Status: 
Offline

  back to top

Thanks for the reply,
I think I tried that initially and have just retried it but linking to the counter only updates the counter value and has no affect on the light (It doesn't appear to send the information to C-Bus) Maybe I am missing something?
I have attached an example of what I have done.

Attachment: Counters 1.jpg (Downloaded 15 times)

slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4773
Status: 
Offline

  back to top

You have not mapped the counter to Cbus, at least not that you have shown. The same counter must be mapped to cbus in order to likk the 2 addresses together

waynebr
Member


Joined: Friday May 1st, 2009
Location: United Kingdom
Posts: 89
Status: 
Offline

  back to top

HI I have looked at the manual again as I have the original manual, It looks like I have the original CBUS and not the CBUS2 is mapping only available on the CBUS2?

slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4773
Status: 
Offline

  back to top

Yes the old ucm cbus does not support this. You can get the new ucm/cbus2 if you want this

waynebr
Member


Joined: Friday May 1st, 2009
Location: United Kingdom
Posts: 89
Status: 
Offline

  back to top

Thanks I will get one and try again


UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems