Comfort Home Automation/ Security System Forums Home
Home Search search Menu menu Not logged in - Login | Register

SMS Trouble after power failure
 Moderated by: admin Page:  First Page Previous Page  1  2   
 New Topic   Reply   Printer Friendly 
 Rate Topic 
AuthorPost
 Posted: Tuesday Jan 7th, 2020 11:34 am
   PM  Quote  Reply 
21st Post
caravanboy
Member
 

Joined: Wednesday Mar 8th, 2017
Location: United Kingdom
Posts: 74
Status: 
Offline

  back to top

I think I did do that in the past but I will do it again. I think I only pulled power to my main panel though (which has the GSM module) and not the separate supply to my SEP panel. You could imagine some quirky behaviour if both lose power, or something like that. I will try and also disconnect the network cable from the ETH module as when I lose power that would also effectively lose it's connection, just in case that makes any difference. I'll report back in a few days...



 Posted: Wednesday Jan 8th, 2020 12:48 am
   PM  Quote  Reply 
22nd Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4914
Status: 
Offline

  back to top

I will try and also disconnect the network cable from the ETH module as when I lose power that would also effectively lose it's connection, just in case that makes any difference.
Do not disconnect the ETH03 as that would mean we would not be able to monitor the GSM status
The battery shpuld powere up the Comfort and UCM modules, they should not lose power



 Posted: Wednesday Jan 8th, 2020 08:28 am
   PM  Quote  Reply 
23rd Post
caravanboy
Member
 

Joined: Wednesday Mar 8th, 2017
Location: United Kingdom
Posts: 74
Status: 
Offline

  back to top

yes, okay, good point. I just meant as an optional test (after I've checked signal levels etc) to see if that's the trigger for making the GSM module start to fail



 Posted: Monday Jan 20th, 2020 08:43 pm
   PM  Quote  Reply 
24th Post
caravanboy
Member
 

Joined: Wednesday Mar 8th, 2017
Location: United Kingdom
Posts: 74
Status: 
Offline

  back to top

Hi Slychiu,
I haven't got around to doing a controlled power failure test but I was at home today when we had a 45 min power outage so I did some checks during that power outage:
During the full power failure, my network switch and wifi were on UPS now so I eventually (*see below) got Comfigurator on my laptop to show the GSM4 UCM GSM network signal status. It showed "Good - 3" as the network strength but I had NOT received a power fail SMS text message.
When the AC power returned after ~45 mins, a few minutes later I did then receive a Power restore SMS message. Also, when the AC was restored I then immediately checked the signal strength again and it showed "Fair - 2" and texts are working normally. I never miss one under normal circumstances.
So, I'd say this seems to show that the fault is very likely with Comfort. I can still do a controlled test power failure (i.e. Comfort main panel only) if needed, but the fact that the GSM module claimed to have a good signal strength does point a Comfort bug somewhere.

* I think there is a minor Comfigurator bug/quirk - if you launch and open the config, navigate to the relevant GSM4 Module and click "Get Status", it asks you for the PIN to login, but then does not immediately show the status. Trying again now I think it puts you on to a different page and you have to navigate back to that page, but maybe I did not notice that earlier during the power failure. 
Also, when I was in power fail situation, the "GSM Network Strength..." message appeared in red for a couple of seconds and was then replaced by "Normal/No error" in black and no mater how long I waited the signal strength message didn't reappear without me navigating away from the module and back again.  Now I'm in AC-okay mode, it still does mostly stay on "Normal/No error" but does regularly (every 30 seconds or more?) switch to the signal status message, but still only for a couple of seconds. Not 



 Posted: Tuesday Jan 21st, 2020 02:51 am
   PM  Quote  Reply 
25th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4914
Status: 
Offline

  back to top

We have bot been able to find any problem with diak out during power failure
Please upgrade to GSM4 7.128 Beta firmware which has some improvements in operation which may or may not have an effect on your probelmsfrom http://www.cytech.biz/product_details.php?item_id=227



 Posted: Tuesday Jan 21st, 2020 07:51 am
   PM  Quote  Reply 
26th Post
caravanboy
Member
 

Joined: Wednesday Mar 8th, 2017
Location: United Kingdom
Posts: 74
Status: 
Offline

  back to top

Ok, thanks, I'll download and try that over the next week or so and let you know.

Before installing the new firmware, I will still try and do the manual controlled power failures (of my Comfort main panel, and SEM01 panel) as they are on different circuits within the house, just so I have that info to help with the diagnosis too



 Posted: Monday Jan 27th, 2020 07:36 pm
   PM  Quote  Reply 
27th Post
caravanboy
Member
 

Joined: Wednesday Mar 8th, 2017
Location: United Kingdom
Posts: 74
Status: 
Offline

  back to top

I did some manual power failure tests as follows but all worked as expected:
1) Power fail on main panel - official Comfort SMS received OK, voice call OK, test SMS worked during power failure, AC Restore SMS worked ok.
2) Power fail Slave panel only - no Comfort SMS (as expected), test SMS worked during power failure.
3) Power fail Slave, then power fail main panel (approx. 2 mins later) - official Comfort SMS received OK, voice call OK, test SMS worked during power failure, AC Restore SMS worked okay.
So, I just need to remember how to upgrade firmware now as I've not done it for a couple of years. Comfigurator only seems to offer me a "by cable" option. Hmm 
I guess I can then just have the latest beta GSM4 firmware installed and wait for the next full power failure.  Perhaps the issue is caused only when the main and slave panels fail at exactly the same moment?



 Posted: Tuesday Jan 28th, 2020 01:48 am
   PM  Quote  Reply 
28th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4914
Status: 
Offline

  back to top

You donthave to use the firmware upgradingt cable if your UCM and Comfort are version 6 and above

see http://www.comfortforums.com/forum92/3400.html for instructions



 Posted: Tuesday Jan 28th, 2020 06:37 pm
   PM  Quote  Reply 
29th Post
caravanboy
Member
 

Joined: Wednesday Mar 8th, 2017
Location: United Kingdom
Posts: 74
Status: 
Offline

  back to top

Thanks. GSM4 successfully updated to beta 7.128 firmware. Basic GSM tests appear okay. Will await next full AC failure (sadly shouldn't be too long given recent power outages in our area) and will report back after that



 Current time is 03:31 amPage:  First Page Previous Page  1  2   
Top




UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems