Comfort Home Automation/ Security System Forums Home
Home Search search Menu menu Not logged in - Login | Register

Communication error - Zwave problem
 Moderated by: slychiu Page:  First Page Previous Page  1  2  3   
 New Topic   Reply   Printer Friendly 
 Rate Topic 
AuthorPost
 Posted: Saturday Aug 19th, 2017 06:54 am
   PM  Quote  Reply 
41st Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4028
Status: 
Offline

  back to top

Polling has always been a big problem in Zwave. Devices are not allowed to automatically give their status when it changes. The controller has to poll ie send a Get Status command to each device that it wants status. This means that in order to know the status of many devices, the controller must constantly poll each device as it would not know when its state would change. This is undesirable as it causes a lot of RF traffic and is discouraged by Zwave.

For a virtual node in UCM/Zwave, the controller also has to poll its status
Ian has mapped virtual nodes to Flags in Comfort. The Zone On response sets the flag and Zone Off response clears the flag. The Homeseer controller polls the virtual node to get the status of the flag ie zone

The new action code in the firmware sends a Status Update command from the virtual node to the controller node. Status Update is normally a reply to a Get Status command ie a Poll. The new action sends a status update without waiting for a poll. It appears this works for Homeseer but it is not known if other controllers will handle in the same way.



 Posted: Wednesday Aug 23rd, 2017 07:46 am
   PM  Quote  Reply 
42nd Post
Ian
Member
 

Joined: Saturday Aug 19th, 2006
Location: United Kingdom
Posts: 76
Status: 
Offline

  back to top

If anybody else is using Homeseer;
It seems that HomeSeer recognises the change to ON in the Z-wave virtual node as a change to LAST.
ON is 99 and LAST is 255. OFF is 0
When triggering events I am using 'The device had its value set and is greater than, 99.
For OFF I simply use OFF.



 Posted: Thursday Aug 24th, 2017 01:57 am
   PM  Quote  Reply 
43rd Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4028
Status: 
Offline

  back to top

Hi Ian,
Did you manage to get alll the other zones reporting the sttaus using the new action?



 Posted: Thursday Aug 24th, 2017 06:09 am
   PM  Quote  Reply 
44th Post
Ian
Member
 

Joined: Saturday Aug 19th, 2006
Location: United Kingdom
Posts: 76
Status: 
Offline

  back to top

I did - thank you.
I can now have an instant status of the alarm reporting in Homeseer. That allows me to program events in Homeseer as the alarm is set to Away, Off, Night or Day as well as other states such as smoke alarm and intruder alert.

Last edited on Thursday Aug 24th, 2017 09:02 am by Ian



 Posted: Friday Aug 25th, 2017 03:15 am
   PM  Quote  Reply 
45th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4028
Status: 
Offline

  back to top

That seems to be a useful feature.
However it is not known if it will work with other controllers like Fibaro, Vera, etc as each may handle differently



 Posted: Friday Aug 25th, 2017 07:57 am
   PM  Quote  Reply 
46th Post
leonchue
Cytech
 

Joined: Monday Aug 7th, 2006
Location: Singapore
Posts: 71
Status: 
Offline

  back to top

Ian wrote: If anybody else is using Homeseer;
It seems that HomeSeer recognises the change to ON in the Z-wave virtual node as a change to LAST.
ON is 99 and LAST is 255. OFF is 0
When triggering events I am using 'The device had its value set and is greater than, 99.
For OFF I simply use OFF.

Triggering events using "The device had its value set and is greater than, 0." will be better.



 Current time is 02:15 amPage:  First Page Previous Page  1  2  3   
Top




UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems