Comfort Home Automation/ Security System Forums Home
Home Search search Menu menu Not logged in - Login | Register

IR Transmission Problem
 Moderated by: slychiu
 New Topic   Reply   Printer Friendly 
 Rate Topic 
AuthorPost
 Posted: Thursday Dec 29th, 2016 05:13 pm
   PM  Quote  Reply 
1st Post
RahulPandey686
Member
 

Joined: Thursday Jul 21st, 2016
Location:  
Posts: 18
Status: 
Offline

  back to top

I have Comfort II ULTRA and was trying to switch on/off my Panasonic CS-UC-18RKY3-2 AC using IR transmitting LED on Output 1 (red wire to 12V & black to OP1) through response IR1Output1 but not getting anything

have stored on/off Infrared signal using UCM/USB module from my Panasonic handheld remote controller

Tested & Checked the infrared LED using my Multi-meter and phone camera

and one more thing the placement of transmitting LED is just over the receiving sensor of AC(some few mm distance apart) and also tried placing at far distance

Please! help what should I do.

Attachment: IR transmission.png (Downloaded 29 times)

Last edited on Friday Dec 30th, 2016 02:21 pm by RahulPandey686



 Posted: Thursday Dec 29th, 2016 05:24 pm
   PM  Quote  Reply 
2nd Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4230
Status: 
Offline

  back to top

please send the cclx file to support@cytech.biz so we can look at the IR signals



 Posted: Friday Dec 30th, 2016 02:09 pm
   PM  Quote  Reply 
3rd Post
RahulPandey686
Member
 

Joined: Thursday Jul 21st, 2016
Location:  
Posts: 18
Status: 
Offline

  back to top

I have send the email containing the cclx file, please reply

Last edited on Friday Dec 30th, 2016 02:23 pm by RahulPandey686



 Posted: Saturday Dec 31st, 2016 06:22 am
   PM  Quote  Reply 
4th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4230
Status: 
Offline

  back to top

Replied  by email also

It seems (from your infrared signal) that you may have pressed the remote control button too long while learning the IR signal
Just press and release the button that you want to learn
Learn several buttons, not just a single button eg 20 deg On/Off, 21, deg on/off, 22 deg on/off etc in case one of the buttons is not learned correctly


test the IR command using the Execute Response button in your screenshot to quickly test the signal
In the Monitor I/O window, after the IR signal is sent to Output 1 you should see IR0101 eg



 Posted: Saturday Dec 31st, 2016 10:27 am
   PM  Quote  Reply 
5th Post
RahulPandey686
Member
 

Joined: Thursday Jul 21st, 2016
Location:  
Posts: 18
Status: 
Offline

  back to top

I did as you said :

1. learn more signals
learned at 20deg, 22, 18, 24, 21, 19
2. short press of remote key
and checked Monitor I/O Windows & it showed
< RA0000 in blue color (?)
< OP0100 in blue color (when execute IR1Output1)
> DA800100FF in Red color (want to know, what it is ?)
< RA0000
< OP0100
> DA810105FF again in red ?
< RA0000
< IR0500 in blue (when execute IR9Output5 self created, also change the connection of IR to this output)

but over all AC is not switching On/Off using Comfort Ultra II CP9000

also tried to check weather the connection to the IR LED is healthy and IR Working or not by executing the Output1ON response to switch on IR LED and Output1OFF to switch it off
and checked the IR LED emitting light using mobile camera
> DA800101FF in red
< RA0000 in blue
< OP0101 in blue (switch on out 1)
> DA800100FF
< RA0000
< OP0100 (switch off out 1)

Last edited on Saturday Dec 31st, 2016 10:30 am by RahulPandey686



 Posted: Saturday Dec 31st, 2016 11:05 am
   PM  Quote  Reply 
6th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4230
Status: 
Offline

  back to top

There is a problem with your responses
IR1Output1 should show IR0101 NOT OP0101
OP0101 means Output 1 is turned ON
Your response name does not match your response contents. check it again

You should never turn on an IR Output as that permament on state can damage your Infrared transmiiter which should be pulses with an IR signal only

Make your won response IR signal X to Output Y wirte to Comfort and test again

IR0500 means Output 5 tramnsitted IR 0 as you have no IR 9 but that is the correct form of the command



 Posted: Saturday Dec 31st, 2016 11:30 am
   PM  Quote  Reply 
7th Post
RahulPandey686
Member
 

Joined: Thursday Jul 21st, 2016
Location:  
Posts: 18
Status: 
Offline

  back to top

yes OP0101 is the response of output 1 turned on i did it intentionally to check my IR diode is working or not,

can this damage the IR Sensor ?

but the IR sensor is still emitting the purple Light when directly switch on using supply/ multi-meter in order to check

so how I can check my IR transmitter is working or not ?
Please! guide or tell that I need to change it.

The IR9Output5 is created by me and tested but not working(------ Make your won response IR signal X to Output Y wirte to Comfort and test again)



 Posted: Saturday Dec 31st, 2016 11:45 am
   PM  Quote  Reply 
8th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4230
Status: 
Offline

  back to top

You Must get IR0101 when sending IR 1 to Output 1 otherwise you have done the wrong response
check the response write to Comfort and do execute response IR1 to Output 1
It must show IR0101 othewrwise your response is incorrect

If you have another IR transmitter then use that and do not set the output on continbuously. But do not connect it until you have checked that the command is IR0101

You can also enter IR0101 direct in IO monitor



 Posted: Monday Jan 2nd, 2017 01:03 pm
   PM  Quote  Reply 
9th Post
RahulPandey686
Member
 

Joined: Thursday Jul 21st, 2016
Location:  
Posts: 18
Status: 
Offline

  back to top

I was getting the right responses, I just posted wrong responses with the wrong description, sorry for that

here is the image with the right responses, but still not able to run AC

Attachment: panasonic ac ir trans.png (Downloaded 21 times)

Last edited on Monday Jan 2nd, 2017 01:12 pm by RahulPandey686



 Posted: Monday Jan 2nd, 2017 01:51 pm
   PM  Quote  Reply 
10th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4230
Status: 
Offline

  back to top

IR0100 means there is no valid iR code at IR code 1
Please send the correct cclx file to support@cytech.biz
make sure you save the file becfore sending it



 Posted: Monday Jan 2nd, 2017 02:49 pm
   PM  Quote  Reply 
11th Post
RahulPandey686
Member
 

Joined: Thursday Jul 21st, 2016
Location:  
Posts: 18
Status: 
Offline

  back to top

thanks for the quick reply,

I have send the new cclx file as requested to the given email id

Thankyou



 Posted: Wednesday Jan 4th, 2017 09:33 am
   PM  Quote  Reply 
12th Post
RahulPandey686
Member
 

Joined: Thursday Jul 21st, 2016
Location:  
Posts: 18
Status: 
Offline

  back to top

Thankyou for Everything,

Now its working fine

problem was writing cclx file in comfort

thanks again

Last edited on Wednesday Jan 4th, 2017 09:33 am by RahulPandey686



 Posted: Friday May 18th, 2018 01:58 pm
   PM  Quote  Reply 
13th Post
bagushandhoko
Member
 

Joined: Saturday Jul 25th, 2015
Location: Jakarta, Indonesia
Posts: 83
Status: 
Offline

  back to top

Hi Rahul/Slychiu,
  1. so the problem solved by writing the program to comfort ? before you hasn't yet wrote it ? 
  2. please check the attachment, IR signal working ?
After several years install the system , its time to utilize IR feature in comfort, I have same problem several years ago when tried the feature 

Attachment: IMG_20180518_224724.jpg (Downloaded 6 times)

Last edited on Friday May 18th, 2018 03:54 pm by bagushandhoko



 Current time is 12:45 pm
Top




UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems