Comfort Home Automation/ Security System Forums Home

 Moderated by: slychiu  
AuthorPost
Ian
Member
 

Joined: Saturday Aug 19th, 2006
Location: United Kingdom
Posts: 176
Status: 
Offline

  back to top

I have a Comfort II with Zwave3 UCM.My primary zwave control is HomeSeer with a Z-Wave.me UZB stick.I have set up zwave within Comfort, it shows the physical nodes from my existing controller as well as some virtual nodes I have set up.I can control zwave devices from Comfort and control the virtual devices from HomeSeer.
So far so good.
I have a plugin socket that has 'Counter' as its 'Registered type', it is mapped to Counter 11.When I turn the socket on or off I see the counter value change in Comfort (via Comfigurator).
I also have a battery operated zwave sensor on a window. This appears in Comfort (having learned from the existing zwave network) and it is also mapped to a Counter, Counter 10. I know the sensor works as I get a response from HomeSeer, but the counter does not update in Comfort.
I suspect that it may be related to the sensor having a number of child devices but if that is the case, how can I get Comfort to recognise a change in a Child device?
Cheers
Ian

Last edited on Wednesday Sep 7th, 2016 06:18 pm by Ian

leonchue
Cytech
 

Joined: Monday Aug 7th, 2006
Location: Singapore
Posts: 71
Status: 
Offline

  back to top

Battery operated device is usually in "sleep" mode to conserve power.  When in this mode, the device will not respond to any transmissions.  Hence, the counter mapping is unnecessary. 

To have the latest battery operated device status, associate it with a new virtual node.  This virtual node may mapped to a flag/counter.  

After association, whenever the battery operated device changes state, it will change the virtual node state as well.  If it is mapped to flag, the flag will indicate the current device status.

Ian
Member
 

Joined: Saturday Aug 19th, 2006
Location: United Kingdom
Posts: 176
Status: 
Offline

  back to top

Thanks for the reply.Work got in the way of sorting this out.The device appears as a Routing slave. Is it possible to associate directly with a virtual node in Comfort or does it need to be done via a controller?
Cheers

slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4910
Status: 
Offline

  back to top

A routing slave can be associated with a virtual Node in Comfort
The UCM/Zwave manual  shows how to do this

http://www.cytech.biz/ucmzwave_manual.html

Ian
Member
 

Joined: Saturday Aug 19th, 2006
Location: United Kingdom
Posts: 176
Status: 
Offline

  back to top

Thanks for getting back to me.
I see in the manual;
To use a Primary Controller to associate a Routing Slave to a Virtual Node; The
procedure below is for the MK LR14S controller - other devices will have their own
procedure which is found in their instruction manuals.
1 Put the Controller into Association Mode by pressing and hold the ASC button
until its ASC led turns on Yellow.
2 Press the button on the Target slave node to be associated, i.e. UCM/Zwave.
This is the Virtual Node Info - SEND button. The ASC led will flash green 3
times to indicate receiving of the target device data.
3 Repeat for other target devices to be associated with the Source device, i.e.
other Z-Wave slave devices. A source device can be associated with many
target devices.
4 Press and release (not HOLD) the ASC button. The ASC led will turn Red to
indicate that the next device to be received will be the source node.
5 Press the button on the source slave node to be associated to the Virtual Node.
6 The ASC led will flash green 2 times to indicate receiving of the source slave
data and will turn off to indicate exit from Association Mode.

My question was whether or not it could be done without using a Primary Controller

slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4910
Status: 
Offline

  back to top

You need a primary controller to do the association, the same one that was use to add the UCM/Zwave
It shoukd be still available?

Ian
Member
 

Joined: Saturday Aug 19th, 2006
Location: United Kingdom
Posts: 176
Status: 
Offline

  back to top

Thank you.


UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems