Comfort Home Automation/ Security System Forums Home
Home Search search Menu menu Not logged in - Login | Register

Comfigurator 3.10.3 to 3.10.11
 Moderated by: admin
 New Topic   Reply   Printer Friendly 
 Rate Topic 
AuthorPost
 Posted: Thursday May 14th, 2015 10:57 am
   PM  Quote  Reply 
1st Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4172
Status: 
Offline

  back to top

Comfigurator 3.10.3 fixes bugs from 3.9.9

Bugs Fixed
  1. For UCM/Zwave, the Virtual Node Info button was missing
  2. KT03 Button programmed to activate Response did not work - it sent Keypad key command instead
  3. Fixed bug From Comfigurator 3.9.5.  Read from Comfort will cause Functions > Thermostats to fill up the unused Thermostats with sensor 0 and assign Heating and Cooling Outputs to Output 1. You will not be able to control Output 0 after reading from Comfort.  In order to free up Output 0, unassign the outputs from each Thermostat
Known Issues
  1. In KNX configurator, test buttons for KNX Group address 1/7/X do not work, but action codes to send commands to 1/7/X are not affected
  2. In Cbus configurator, test buttons for Cbus group address 15 do not work but action codes to send commands to Group addesss 15 are not affected
  3. Zones and Control Menu have "Alternate Phrases" where you can enter any text other than the set of words in the vocabulary. This is used in SMS messages for UCM/GSM4 and in the Comfort apps. When the text in alternative phrase is entered and then deleted, the field remains as blank and a blank Button appears in the Comfort Apps. This will be corrected in the next Comfigurator
  4. For KT03, read from KT03 where a button is set to Status = Zone > 64 will result in the zone being blank (unassigned)
  5. In Zwave, after doing a Learn from Zwave, Flag mappings are changed into Counters in Zwave Mappings in Comfigurator.  However this does not affect the actual mappings in the UCM/Zwave, only in the displayed mappings in Comfigurator. To workaround, do another Read from EEPROM for Zwave.

Last edited on Saturday Jan 23rd, 2016 05:51 am by slychiu



 Posted: Monday May 25th, 2015 05:35 pm
   PM  Quote  Reply 
2nd Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4172
Status: 
Offline

  back to top

Comfigurator 3.10.4 has the following changes;
  • In Responses, "Execute Response" button is above the User Comments so it can be easily seen
  • In KT03 Configurator, Write KT03 System Properties and Read KT03 System Properties buttons have been added. KT03  system properties are added. Requires KT03 7.070, ULT 7.076, UCM 7.069 minimum firmware
  • New Action Divide has been added (requires Comfort Firmware 7.076), see http://www.comfortforums.com/forum92/4220.html
  • Exception in Show References when show status button is checked has been fixed
Known Issues
  1. In KNX configurator, test buttons for KNX Group address 1/7/X do not work, but action codes to send commands to 1/7/X are not affected
  2. In Cbus configurator, test buttons for Cbus group address 15 do not work but action codes to send commands to Group addesss 15 are not affected
  3. Zones and Control Menu have "Alternate Phrases" where you can enter any text other than the set of words in the vocabulary. This is used in SMS messages for UCM/GSM4 and in the Comfort apps. When the text in alternative phrase is entered and then deleted, the field remains as blank and a blank Button appears in the Comfort Apps. This will be corrected in the next Comfigurator
  4. For KT03, read from KT03 where a button is set to Status = Zone > 64 will result in the zone being blank (unassigned).
  5. In Zwave, after doing a Learn from Zwave, Flag mappings are changed into Counters in Zwave Mappings in Comfigurator.  However this does not affect the actual mappings in the UCM/Zwave, only in the displayed mappings in Comfigurator. To workaround, do another Read from EEPROM for Zwave.

Last edited on Saturday Jan 23rd, 2016 05:52 am by slychiu



 Posted: Sunday Aug 23rd, 2015 06:32 am
   PM  Quote  Reply 
3rd Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4172
Status: 
Offline

  back to top

Comfigurator 3.10.5 has the following changes

Known Issues
  • Module scan may wrongly detect RIO as iRIO
  • For KT03, read from KT03 where a button is set to Status = Zone > 64 will result in the zone being blank (unassigned)
  • In Zwave, after doing a Learn from Zwave, Flag mappings are changed into Counters in Zwave Mappings in Comfigurator.  However this does not affect the actual mappings in the UCM/Zwave, only in the displayed mappings in Comfigurator. To workaround, do another Read from EEPROM for Zwave.
Changes and Features
  • Configuration > Modules and Settings > Temperature Units has been added. This will set the global temperature unit for temperature functions in future modules like iRIO
  • When Comfigurator is writing and  reading or upgrading firmware via UCM/ETH03, other connections using the 2nd port are blocked to prevent interrupting the transfer. This affects the Comfort apps.
  • Response Wizard - added Arithmetic category which includes Add, Divide, Mulitply, Convert C to F, F to C, Get High Byte,Get Low Byte, Get Parameter value
  • IN KNX Configurator, KNX to Comfort tab, Test Buttons, some group addresses were not working eg 1/7/1. This has been fixed
  • IN Cbus2 Configurator,  Test Buttons, some group addresses were not working eg Group address 15. This has been fixed
  • In Zwave Configurator, Virtual Nodes can now be mapped to non-unique registers, ie registers that were mapped to other virtual or non virtual nodes. This is so that Zwave switches can immediately update the status to the Virtual Node counter or flag when the zwave button is pressed without waiting for the next Poll. However Nonvirtual nodes still cannot be mapped to registers that are already mapped to other nonvirtual nodes.
  • The "Download Firmware Upgrade " (right click on Controller or module) used to cause a log in to the system, hence this cannot be done unless  you are connected to the system. Now it is no longer necessary to log in, so you can Download the firmware upgrade when you are not connected to the system, and later when you are connected to the system (ie at customer site) you can "Upgrade firmware from local file.
  • In GSM4 configurator, the button "Load Default Values" has been changed to "Copy from Comfort" so the purpose of the button  is clearer. It is to copy the values of Zone names, User names and Control Menu names to GSM4
  • iRIO module has been added
  • In Zwave, after doing a Learn from Zwave, Counter mappings are changed into Flags in Zwave Mappings in Comfigurator.  However this does not affect the actual mappings in the UCM/Zwave, only in the displayed mappings in Comfigurator
    To workaround, do another Read from EEPROM for Zwave.

Last edited on Saturday Jan 23rd, 2016 05:52 am by slychiu



 Posted: Friday Sep 4th, 2015 04:23 am
   PM  Quote  Reply 
4th Post
tech07
Administrator
 

Joined: Thursday Jan 29th, 2009
Location: Singapore
Posts: 106
Status: 
Offline

  back to top

Comfigurator 3.10.5 has been released



 Posted: Saturday Sep 26th, 2015 07:53 am
   PM  Quote  Reply 
5th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4172
Status: 
Offline

  back to top

Comfigurator 3.10.6

Known Issues
  1. For KT03, read from KT03 where a button is set to Status = Zone > 64 will result in the zone being blank (unassigned)
  2. In Zwave, after doing a Learn from Zwave, Counter mappings are changed into Flags in Zwave Mappings in Comfigurator.  However this does not affect the actual mappings in the UCM/Zwave, only in the displayed mappings in Comfigurator. To workaround, do another Read from EEPROM for Zwave.
Bugs Fixed
  1. Scan for SCS/IRIO detects RIO as IRIO
  2. Inserting Else in a Response between If and EndIf  caused Exception
  3. Fixed Read from Comfort Exception when iRIO is present

Changes
Support for IRIO

Last edited on Saturday Jan 23rd, 2016 05:52 am by slychiu



 Posted: Monday Oct 5th, 2015 05:18 pm
   PM  Quote  Reply 
6th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4172
Status: 
Offline

  back to top

Comfigurator 3.10.6 has been released
Please upgrade



 Posted: Saturday Nov 7th, 2015 09:35 am
   PM  Quote  Reply 
7th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4172
Status: 
Offline

  back to top

Comfigurator 3.10.8 (Beta) changes

Known Issues
  1. In Zwave, after doing a Learn from Zwave, Flag mappings are changed into Counters in Zwave Mappings in Comfigurator.  However this does not affect the actual mappings in the UCM/Zwave, only in the displayed mappings in Comfigurator. To workaround, do another Read from EEPROM for Zwave.

Bugs Fixed
  1. UCM/CBUS2 Limit of concatenated bytes is limited to 17 so that there is no overflow. Previous versions limited it to 18 bytes which is too much.
  2. In KT03 where write to KT03 failed to any reason, the message "KT03 Upgrade timed out" was changed to "Write/Read to KT03 Timed out"
  3. In KT03, if a button has a status for Zone > 64, read from KT03 will cause the zone to be blank
  4. Fixed BUG. After Module scanning, KP06 and KP04A mdoules which are removed from the system were not shown. They should be shown in red with the status "Not Found". Only Modules with properties in memory eg UCM/KNX, KP06, KT03 etc will be shown as Not Found. Modules that do not have saved properties will not be shown at all in the modules list if they are removed from the system.

New Features
  1. Scanning for Modules has been speeded up greatly. What took up to 1 minute now takes only a few seconds, due to a new  scanning method. This requires Comfort Firmware 7.090 (now in Beta). Older firmware will use the old scanning method.
  2. For Logic Engine, the message "Vocabulary does not match" has been removed, since Logic Engine does not have a vocabulary
  3. Timers (in Names > Timers) has a field  called  Timer Status. The "Show Status" button will show the Timer as OFF or ON, and if ON, the remaining timer in seconds is displayed. This is a useful tool when programming and testing Timers.           
  4. "Clear Event Log" button has been added to the Event Log window. It is good practice to Save the event log and delete it so that old events are not lost    
  5. In System Information, "Vocabulary Number" eg 5, has been changed to "Vocabulary Name" eg "English Residential"
  6. The Action "Send RS232" applies to all UCMs, not just the general UCM, so that new commands can be sent to other UCMs which are not supported before.

Last edited on Saturday Jan 23rd, 2016 05:53 am by slychiu



 Posted: Saturday Nov 21st, 2015 05:43 am
   PM  Quote  Reply 
8th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4172
Status: 
Offline

  back to top

Comfigurator 3.10.9 changes
  1. Fixed issue on scanning for modules using the u?00 command which did not work for ULT 7.090 to 7.092
  2. Send RS232 action in Hex mode accepts space as separator between bytes as well as comma
  3. UCM/eHomegreen fixed scanning for modules problem
Bugs
  1. In Zwave, after doing a Learn from Zwave, Flag mappings are changed into Counters in Zwave Mappings in Comfigurator.  However this does not affect the actual mappings in the UCM/Zwave, only in the displayed mappings in Comfigurator. To workaround, do another Read from EEPROM for Zwave. ]
  2. Virtual Node in Zwave Configurator  Virtual Node Info - SEND button n the right pane is missing from Comfigurator 3.10.9 

Last edited on Saturday Jan 23rd, 2016 10:08 am by slychiu



 Posted: Thursday Dec 17th, 2015 03:46 pm
   PM  Quote  Reply 
9th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4172
Status: 
Offline

  back to top

Comfigurator 3.10.10 has the following changes;
  1. Scan for Modules with ULT 7.092 has been improved so that the entire scan takes less than 20 seconds. A problem with the previous Comfigurator which causes duplicate entries for modules has been fixed
  2. Fixed various bugs in HIO and IRIO
  3. For Logic Engine without voice, the warning that Vocabulary does not match before write to Comfort has been removed
Known Bugs
  1. In Zwave, after doing a Learn from Zwave, Flag mappings are changed into Counters in Zwave Mappings in Comfigurator.  However this does not affect the actual mappings in the UCM/Zwave, only in the displayed mappings in Comfigurator. To workaround, do another Read from EEPROM for Zwave. 
  2. Virtual Node in Zwave Configurator  Virtual Node Info - SEND button n the right pane is missing from Comfigurator 3.10.9 

Last edited on Saturday Jan 23rd, 2016 10:08 am by slychiu



 Posted: Friday Dec 18th, 2015 06:18 am
   PM  Quote  Reply 
10th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4172
Status: 
Offline

  back to top

Please note that there will be an exception if "Remember Sign in" is set to "True" in Options
If this happens copy the attached dll file after unzipping it into the Comfigurator folder
A new version will be generated to fix this

Attachment: Unmanaged.zip (Downloaded 3 times)



 Posted: Friday Dec 18th, 2015 10:08 am
   PM  Quote  Reply 
11th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4172
Status: 
Offline

  back to top

Bug in 3.10.10  beta
  • Missing file unmanaged.dll as described above
Bugs
  1. In Zwave, after doing a Learn from Zwave, Flag mappings are changed into Counters in Zwave Mappings in Comfigurator.  However this does not affect the actual mappings in the UCM/Zwave, only in the displayed mappings in Comfigurator. To workaround, do another Read from EEPROM for Zwave. 
  2. [size=In Zwave, after doing a Learn from Zwave, Flag mappings are changed into Counters in Zwave Mappings in Comfigurator.  However this does not affect the actual mappings in the UCM/Zwave, only in the displayed mappings in Comfigurator. To workaround, do another Read from EEPROM for Zwave. ]

Last edited on Saturday Jan 23rd, 2016 10:07 am by slychiu



 Posted: Saturday Dec 19th, 2015 04:37 am
   PM  Quote  Reply 
12th Post
bagushandhoko
Member
 

Joined: Saturday Jul 25th, 2015
Location: Jakarta, Indonesia
Posts: 82
Status: 
Offline

  back to top

my comfigurator is 3.10.6.0 ...why when check update ..system inform its the latest ?



 Posted: Saturday Dec 19th, 2015 05:15 am
   PM  Quote  Reply 
13th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4172
Status: 
Offline

  back to top

3.10.6 is the latest released version. Others are beta versions



 Posted: Saturday Dec 19th, 2015 05:42 am
   PM  Quote  Reply 
14th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4172
Status: 
Offline

  back to top

The following issues are not new to 3.10.10 but was reported wrongly as new issues;
  • Selective Read from blank template results in Blank Responses. Use Full Read to avoid this problem - This happens when eg Time Program or other item with a  Response is read by selective read contains a Response number which is not present in the Responses.  This results in the Response becoming Null.
  • After any Read operation, Comfigurator logs out by itself. This was the previous behaviour



 Posted: Tuesday Dec 22nd, 2015 06:59 am
   PM  Quote  Reply 
15th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4172
Status: 
Offline

  back to top

Comfigurator 3.10.11 fixes the problem of missing dll file in the distribution



 Current time is 02:53 pm
Top




UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems