Comfort Home Automation/ Security System Forums Home
Home Search search Menu menu Not logged in - Login | Register

Comfort to CBUS Physical Inputs and Lighting
 Moderated by: admin
 New Topic   Reply   Printer Friendly 
 Rate Topic 
AuthorPost
 Posted: Friday Aug 22nd, 2014 09:59 am
   PM  Quote  Reply 
1st Post
Howser
Member
 

Joined: Monday May 22nd, 2006
Location: Pretoria, South Africa
Posts: 194
Status: 
Offline

  back to top

I am using CBUS2 (version 7.054) and it is truly remarkable. 

Would it be possible to change the UI to allow installers to specify which CBUS group address they would like to add to the Lighting Section? If I click on Add Group Address, the UI determines first GA that is not in the table and adds that (for example I do not use GA 0, so it will add that first). I set-up my groups with future expansion in mind, so there are GA that I do not use for now, and every time I want to add a new GA, the UI tries to fill gaps first, which means I have to delete those that I do not once it reaches the GA I want, or I would need to change the project file manually (which is what I have been doing). 

I have a question about  the Physical Inputs. Currently you cannot add or delete them, which means unused inputs will show up as having references with a blue foreground. Would it be possible to either remove the references or maybe allow installers to specify the inputs they would like to use?

One last question. There are conditions in which Comfort will send all the input statuses to CBUS. Would it be possible to either allow installers to specify which inputs, or have a logical condition check which only sends the inputs that are actually used/referenced? 



 Posted: Friday Aug 22nd, 2014 12:49 pm
   PM  Quote  Reply 
2nd Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3497
Status: 
Offline

  back to top

Would it be possible to change the UI to allow installers to specify which CBUS group address they would like to add to the Lighting Section? If I click on Add Group Address, the UI determines first GA that is not in the table and adds that (for example I do not use GA 0, so it will add that first). I set-up my groups with future expansion in mind, so there are GA that I do not use for now, and every time I want to add a new GA, the UI tries to fill gaps first, which means I have to delete those that I do not once it reaches the GA I want, or I would need to change the project file manually (which is what I have been doing).

Actually you do not have to delete the added group addresses
If the group address is not assigned to any Comfort register it has no effect

How about using the exported cbz file, which automatically fills up the tables based on the applications found in the file? This would be the most efficient and fastest way


I have a question about the Physical Inputs. Currently you cannot add or delete them, which means unused inputs will show up as having references with a blue foreground. Would it be possible to either remove the references or maybe allow installers to specify the inputs they would like to use?
I see the problem. we will see if that can be improved


There are conditions in which Comfort will send all the input statuses to CBUS. Would it be possible to either allow installers to specify which inputs, or have a logical condition check which only sends the inputs that are actually used/referenced?
I believe comfort only send the inputs which have assignment to Lighting group addresses. Have you experienced differently?








 Posted: Friday Aug 22nd, 2014 09:12 pm
   PM  Quote  Reply 
3rd Post
Howser
Member
 

Joined: Monday May 22nd, 2006
Location: Pretoria, South Africa
Posts: 194
Status: 
Offline

  back to top

The export works as an initial step, once you have an existing config, it overrides what you have, unless if this was changed lately on Comfigurator. I understand that that if you do not assign them, then they have no effect, but I prefer to only include groups that have been assigned.

The last point about every input being sent to CBUS, I was not referring to the assigned lighting application, but more on the Security application (208), for example when Comfort is restarted, it send an update of all the inputs, even those that might not be used. It is not a train smasher, but when looking at the logs from CBUS, I would expect to see only inputs that are used.



 Posted: Friday Sep 5th, 2014 03:43 am
   PM  Quote  Reply 
4th Post
Howser
Member
 

Joined: Monday May 22nd, 2006
Location: Pretoria, South Africa
Posts: 194
Status: 
Offline

  back to top

Howser wrote: The last point about every input being sent to CBUS, I was not referring to the assigned lighting application, but more on the Security application (208), for example when Comfort is restarted, it send an update of all the inputs, even those that might not be used. It is not a train smasher, but when looking at the logs from CBUS, I would expect to see only inputs that are used.
It seems to do the same thing, that is send all input status to CBUS (including those that are not used) after midnight when it sends the status of tamper, low battery and line cut.



 Posted: Friday Sep 5th, 2014 04:23 am
   PM  Quote  Reply 
5th Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3497
Status: 
Offline

  back to top

It has to send all the zone status to Cbus, according to the Cbus Security Application documentation
If it does not, it does not comply



 Posted: Friday Sep 5th, 2014 05:00 am
   PM  Quote  Reply 
6th Post
Howser
Member
 

Joined: Monday May 22nd, 2006
Location: Pretoria, South Africa
Posts: 194
Status: 
Offline

  back to top

ident wrote: It has to send all the zone status to Cbus, according to the Cbus Security Application documentation
If it does not, it does not comply 

If I have configured 40 inputs of the 96, why not send all 40? I guess it is not the end of the world as it does not send this status update every minute.



 Current time is 01:49 am
Top




UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems