Comfort Home Automation/ Security System Forums Home
Home Search search Menu menu Not logged in - Login | Register

Graphical References in Comfigurator
 Moderated by: slychiu
 New Topic   Reply   Printer Friendly 
 Rate Topic 
AuthorPost
 Posted: Saturday Aug 2nd, 2014 08:39 am
   PM  Quote  Reply 
1st Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3494
Status: 
Offline

  back to top

Graph References
This is a feature in Comfigurator 3.9.5 which makes it easier to trace how Responses are used in Comfigurator

Right Click on any Response and select "Graph References"



This opens a new window which shows the connections between the Responses and what triggered it as well as what other responses are activated by it



This helps to troubleshoot and debug the programming of Comfort

Cursor over a Node to see Tooltip

Double-click Response Node to make it the Target Response.
A Response node is shown with the lamp icon. Note that only a Response can be a target
Double Click the Target Response (in blue) to Edit the Response

Select a Response from the Responses page to change the Target Response

The boxes are colour coded as follows: the Target Response is in Blue, other Responses are in Green, and other events, ie not Responses like zones, time programs, outputs etc are in White. This helps to identify other Responses which can become the new target by double-clicking on it.

Graph References works on Responses, Zones , Counters, Flags, and Alarms

Last edited on Thursday Jan 1st, 2015 08:38 am by slychiu



 Posted: Saturday Aug 2nd, 2014 10:25 am
   PM  Quote  Reply 
2nd Post
Ingo
UCM Pi Users


Joined: Sunday Jan 21st, 2007
Location: South Africa
Posts: 549
Status: 
Offline

  back to top

Awesome, I like it.



 Posted: Saturday Aug 2nd, 2014 12:10 pm
   PM  Quote  Reply 
3rd Post
juwi_uk
Member


Joined: Friday May 25th, 2007
Location: Newbury, United Kingdom
Posts: 1254
Status: 
Offline

  back to top

Nice work.  I can see there is huge scope to enhance this area too!

Can't see how you present this right now but would be good if there is an option to open this in a new free-floating window rather the main workspace and then when you double click one of the boxes it opens the relevant configuration section in the main workspace.

Julian

Last edited on Saturday Aug 2nd, 2014 04:56 pm by juwi_uk



 Posted: Saturday Aug 2nd, 2014 11:26 pm
   PM  Quote  Reply 
4th Post
cc_uk
Member
 

Joined: Friday Mar 28th, 2014
Location:  
Posts: 65
Status: 
Offline

  back to top

Looks really good - great view of the relationships between elements



 Posted: Wednesday Aug 20th, 2014 04:08 pm
   PM  Quote  Reply 
5th Post
lwillerton
Member
 

Joined: Sunday Oct 2nd, 2011
Location:  
Posts: 218
Status: 
Offline

  back to top

Hi All,

This is going to make some of those more complicated rules easier to track down.

Keep up the good work.

Regards


Lee



 Posted: Sunday May 10th, 2015 04:21 am
   PM  Quote  Reply 
6th Post
mikeinnc
Member
 

Joined: Wednesday Mar 18th, 2015
Location: Perth, Australia
Posts: 69
Status: 
Offline

  back to top

I am finding a problem with the 'Show Reference' command on the Counter tab. I have counters configured to CBus groups, and would like to see where they have been used. However, on the counter page, if the 'Show Status' box has been checked, the 'right click' action on a specific counter is very intermittent - sometimes it shows the dialog and other times, it just creates a small empty box. IF the dialog does show, clicking 'Show Reference' immediately throws an 'Unhandled Exception'. This is consistent on any counter, whether applied to a C Bus group or not. If the 'Show Status' box is unchecked, then the 'Show Reference' dialog works correctly. I'm attaching a screen shot of the unhandled reference. The Comfigurator version is 3.10.2.0

Attachment: UnhandledException.jpg (Downloaded 54 times)

Last edited on Sunday May 10th, 2015 04:23 am by mikeinnc



 Posted: Sunday May 10th, 2015 07:20 am
   PM  Quote  Reply 
7th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4873
Status: 
Offline

  back to top

We verified this and should be able to fix this

In the meantime if you uncheck the show status box, there should be no exception



 Posted: Tuesday May 26th, 2020 08:34 am
   PM  Quote  Reply 
8th Post
CTx
Member
 

Joined: Thursday Apr 9th, 2020
Location: Portugal
Posts: 17
Status: 
Offline

  back to top

I started configuration based on a default Template and worked over it.
Based on this (References) I just noticed that some of my zones (9 and 10) were blue and went after the References (to my surprise as I thought I head written over what was preexisting).
I found references to Responses "TwoWaySwitchOff" and "TwoWaySwitchOn" and "TwoWaySwitchOff01" and "TwoWaySwitchOn01" which mess with OUTPUT1 ...
Something totally unwanted on what I thought was a "clean" configuration.
To correct it I would have to wipe responses 217 and 218 ...
But, will I need them later ?
So, I am getting into new troubles. And just trying to start clean ...
And wandered to what extent that could go on with Configuration items without my knowledge (limited of course) of the many hidden details in Configurator.
Can you please provide some guidance on the value of templates (which I assumed a good base) and how to deal with pre-existing dependencies (such as responses 127 and 128).

Thank you.



 Posted: Tuesday May 26th, 2020 12:28 pm
   PM  Quote  Reply 
9th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4873
Status: 
Offline

  back to top

What you can do is go to Edit > Unfix All Responses, then Delete Unfixed and Unreferenced Responses

This will remove all unused responses so the remaining are in Blue
If you want to keep some unused references then Fix the Response numbers (they will appear in Bold)
There is no point in keeping unused responses. You can always vopy responses from a new template
This will clean up the Graphical references you you see only the ones that are used



 Posted: Tuesday May 26th, 2020 11:05 pm
   PM  Quote  Reply 
10th Post
CTx
Member
 

Joined: Thursday Apr 9th, 2020
Location: Portugal
Posts: 17
Status: 
Offline

  back to top

The "Delete Unfixed and Unreferenced Responses" surely took a lot and left a "to the bones" Response List.

But, how do I copy responses from a new template ?
Not "finger and eye" copy, but by "easy" copy



 Posted: Wednesday May 27th, 2020 03:43 am
   PM  Quote  Reply 
11th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4873
Status: 
Offline

  back to top

Right Click in the Response, select Edit Response Manually, then select the text and Copy to Clipboard
In the new program create the ew Response, Edit Response Manually ad Paste the text intyp it

Another method is Right Click in the Response and use Export Scenario. the response s exported to a file. Then in the new file, go to File > mport Scenario




 Current time is 11:50 pm
Top




UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems