Comfort Home Automation/ Security System Forums Home
Home Search search Menu menu Not logged in - Login | Register
Comfort Home Automation/ Security System Forums > Software Applications > Comfigurator > Comfort or UCM firmware does not support scan function

Comfort or UCM firmware does not support scan function
 Moderated by: admin
 New Topic   Reply   Printer Friendly 
 Rate Topic 
AuthorPost
 Posted: Saturday Jun 1st, 2013 05:17 pm
   PM  Quote  Reply 
1st Post
Ian
Member
 

Joined: Saturday Aug 19th, 2006
Location: United Kingdom
Posts: 121
Status: 
Offline

  back to top

Hi - I have started a new topic as requested.
When I try to upload from PC to Comfort I am getting the error message Comfort or UCM firmware does not support scan function.
I am using V3.6.8.0 of Comfigurator.
When I try to update the UCM firmware (as advised) I get the message Firmware must be version 6 or above to upgrade by this method. Please use UCM Programming Cable instead.



 Posted: Sunday Jun 2nd, 2013 02:20 am
   PM  Quote  Reply 
2nd Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3496
Status: 
Offline

  back to top

what is the firmware version of Comfort and the UCMs?
If  the firmware version is less than 6, then you will need to use the UCM Firmware upgrading cable to upgrade the firmware to the latest (version7). This will allow the scanning function to work
The firmware can be seen on the labels on the UCM and Comfort main microcontroller ICs

Upgrading Comfort II by UCM programming cable is described in http://www.comfortforums.com/forum4/1216.html
Upgrading UCMs and SEM firmware by UCM programming cable is shown in http://www.comfortforums.com/forum4/1782.html
This is to upgrade any Comfort II module with firmware 5.100. Use this method to upgrade firmware from version 5 to 6.




 Posted: Sunday Jun 2nd, 2013 10:35 am
   PM  Quote  Reply 
3rd Post
Ian
Member
 

Joined: Saturday Aug 19th, 2006
Location: United Kingdom
Posts: 121
Status: 
Offline

  back to top

I have Comfort I not II.



 Posted: Sunday Jun 2nd, 2013 10:54 am
   PM  Quote  Reply 
4th Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3496
Status: 
Offline

  back to top

That explains the mystery
Comfort 1 firmware cannot be upgraded as it is based on OTP (One time program) ROM. You should be able to Add modules manually. The UCM and Comfort will not support the scanning function.

Comfigurator now depends a ot on scanning so it may become irrittaing if the scanning always fails
If so please use Comfogurator 2.3, see http://www.cytech.biz/comfigurator_v2.html?category_id=98
 or an earlier version of Comfigurator 3 say 3.56

Comfort 1 is about 8 years old so another option is to upgrade the PCBs and keypads if you plan to be making changes on the programming. Many of the great new features are not in Cokfort 1



 Current time is 08:27 pm
Comfort Home Automation/ Security System Forums > Software Applications > Comfigurator > Comfort or UCM firmware does not support scan function
Top




UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems