Comfort Home Automation/ Security System Forums Home
Home Search search Menu menu Not logged in - Login | Register

Ultra 1 / C-Bus -- possible bug
 Moderated by: admin
 New Topic   Reply   Printer Friendly 
 Rate Topic 
AuthorPost
 Posted: Sunday Aug 20th, 2006 08:48 am
   PM  Quote  Reply 
1st Post
Nick Locke
Member
 

Joined: Saturday Aug 19th, 2006
Location: Woodville, United Kingdom
Posts: 33
Status: 
Offline

  back to top

My C-Bus is planned so that addresses below 128 are reserved for things that Comfort needs to monitor.  Addresses above 128 are used for things which Comfort may need to switch, but does not need to monitor.  This is in-line with the restriction that only the lower addresses can be monitored.

I have this (simple, test) response:

If LastUcmCounter = 255 Then
    Reminder 6 On Keypad 64
End If

associated with Counter 35.  This works exactly as expected - whenever C-Bus Group Address 35 is switched on, Comfort sees it and the reminder is played.

However, when Group Address 163 (which should be completely unrelated and is not monitored by Comfort) is switched on, the response also fires.

It seems to be the same for every counter below 128 - the Group Address that is 128 higher triggers the response in error.

I can engineer a workaround by using addresses below 128, where the Group Address 128 higher is not used - fortunately I only have a small amount of C-Bus!



 Posted: Sunday Aug 20th, 2006 09:49 am
   PM  Quote  Reply 
2nd Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4762
Status: 
Offline

  back to top

Nick
Can you tell me what is the version of your Ultra and UCM/Cbus? I seem to remember that there is a known issue but not sure if it is the same problem



 Posted: Sunday Aug 20th, 2006 05:13 pm
   PM  Quote  Reply 
3rd Post
Nick Locke
Member
 

Joined: Saturday Aug 19th, 2006
Location: Woodville, United Kingdom
Posts: 33
Status: 
Offline

  back to top

slychiu wrote: Can you tell me what is the version of your Ultra and UCM/Cbus?
Yes:

  • Ultra is Action 4.206
  • C-Bus UCM is 5.66
Hope that helps.  Apologies if it is a known issue and I have missed it when searching.

Nick



 Posted: Sunday Aug 20th, 2006 11:24 pm
   PM  Quote  Reply 
4th Post
adlim
Member


Joined: Wednesday May 3rd, 2006
Location: Singapore
Posts: 210
Status: 
Offline

  back to top

It is likely to be a problem of the firmware as Action 4.225 was the version that fixed the problem of counters greated than 127 not being activated.



 Posted: Monday Aug 21st, 2006 02:45 am
   PM  Quote  Reply 
5th Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3495
Status: 
Offline

  back to top

Nick
Ultra Firmware prior to 4.225 were beta versions, 4.225 onwards were release versions. The beta firmware were "at your own risk" as I think Andrew has informed those who bought their systems around that time beforethe Ultra firmware was fully released.
http://www.cytech.biz/versions.html shows the firmware version history

I suggest that you upgrade the firmware to the latest, as that version contains other bugs which you may not have detected

regards



 Posted: Tuesday Aug 22nd, 2006 08:33 pm
   PM  Quote  Reply 
6th Post
Nick Locke
Member
 

Joined: Saturday Aug 19th, 2006
Location: Woodville, United Kingdom
Posts: 33
Status: 
Offline

  back to top

ident wrote: I suggest that you upgrade the firmware to the latest......

Oh dear, do I spend my money on upgrading the firmware, or do I save up my pennies and get a Comfort II......

I have worked around the problem for now by using addresses below 128 where the corresponding address 128 higher is not used for anything......

I can now sit here with that "must have Comfort II" feeling slowly brewing......

Thanks everyone for helping!    Nick



 Current time is 06:14 pm
Top




UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems