Comfort Home Automation/ Security System Forums Home
Home Search search Menu menu Not logged in - Login | Register

Comfigurator 3.7.7 / 3.78
 Moderated by: admin
 New Topic   Reply   Printer Friendly 
 Rate Topic 
AuthorPost
 Posted: Friday Nov 22nd, 2013 08:19 am
   PM  Quote  Reply 
1st Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3497
Status: 
Offline

  back to top

Comfigurator 3.7.7 can be downloaded from http://www.cytech.biz/comfigurator.html

This fixes the  bugs found in 3.7.6 and added some useful features

A number of users reported exceptions in 3.7.6 some of which could not be duplicated. We would like feedback from them whether the exceptions still occur


Known Issues
  1. Read User Codes does not work
  2. Thermostat function registers are displayed by name but not in alphabetic order
  3. Heatmiser display date format in Heatmiser module properties are missing the / separator eg 21/1113 instead of 21/11/13
  4. Execute Responses when the Response is longer than 24 bytes will ask to write to Comfort but after writing, Execute Response will still ask to write to Comfort
  5. Display of Serial Numbers for Comfort is incorrect, shows Invalid. Serial Numbers are correct  for UCMs
  6. When reading event log and Comfigurator is on the GSM4 or Zwave or Heatimiser configuration tab, the event log may get an error message "Event Log Format Invalid.. RA.." The workaround is to move  the cursor away from GSM4, Zwave or Heatmiser UCMs before reading event log
  7. Module Scan may be interrupted by some status reports and give error message "Module Scan Timed out - Please retry later". If this occurs, just redo the Module scan
Bugs Fixed
  1. Action "Add Immediate"  causee Sensor 0 and Counter 0 to show as Referenced in blue. This also occurred  in older versions
  2. Write to KT03 by UCM/ETH02 (not direct to KT03 USB) if a network error closes the connection, does not give the option "Continue from Last Address" so requiring Write to KT03 again. This also occurred  in older versions
  3. When doing module scan by Remote Ethernet connection there may be a wrong message " Comfort firmware 7.xxx does not support Module Scan. Please add modules manually". 
  4. In UCM/Zwave where Switch Multilevel Nodes are mapped to Responses, if the Response number changes in Comfort, the mapped Response number does not change.
  5. When firmware is upgraded to 7.040, some Serial Numbers may be wrongly generated and cause exception
  6. In KT03 Simulation Mode, Flag state was not shown correctly (but is OK on actual KT03)
  7. When a new template is opened, and Scan for Modules is done in a system with a programmed KT03, after the KT03 is scanned, clicking in some of the KT03 pages will cause an Exception.
  8. when upgrading firmware for UCM/KNX, message says "Upgrading firmware to UCM/EIB"
  9. UCM/Zwave compatibility problem for Response created by older Comfigurator 3.6. Empty channel becomes converted to Channel 1 because a blank channel cannot be selected
New Features
  1. Zwave Poll time 0 help text changed to "The  Time Interval (in 10 second units) to poll mapped Zwave nodes for status . 255 means no polling. 0 means Smart Polling from Zwave 7.031"
  2. The Yellow Boxes in Comfigurator right pane used for Response Errors will appear only if there is content. This used to obscure more useful information which required the boxes to be resized
  3. After completing a Scan for Modules, if there is at least 1 "Not Polled" result,  a message will pop uo "One or more modules are not polled. Write Modules to Comfort?". This is useful as people often forget to write modules and settings after adding a module and scanning for it
  4. In Responses, "Duplicate Responses" is now available on Right Click. This duplicates the selected Response, which is useful when many similar responses are needed, differring by soemthing eg counter number
  5. Portugal Defaults changed to the correct Portuguese wordlist
  6. Sunrise/Sunset Times added many Portuguese cities and corrected Time zone

Last edited on Monday Apr 7th, 2014 11:46 am by ident



 Posted: Saturday Nov 23rd, 2013 05:44 am
   PM  Quote  Reply 
2nd Post
simond
Member
 

Joined: Saturday Jan 24th, 2009
Location: United Kingdom
Posts: 28
Status: 
Offline

  back to top

Sadly I got an exception first time I loaded, as per below.
If I open a pre-heatmiser config it works, and then also loads my latest config (with heatmiser).

System.NullReferenceException: Object reference not set to an instance of an object.
at Comfort.UcmHeatmiserMapping.get_RegisterName()
at Comfort.UcmHeatmiserMapping.AddReferences(Dictionary`2 references, UcmHeatmiser ucmHeatmiser)
at Comfort.Configuration.BuildReferences()
at Comfort.Configuration.GetReferences(ConfigListItem configListItem)
at Comfort.Response.FlagOmittedResponses(Configuration configuration)
at Comfort.Response.EncodeResponses(Configuration configuration, Boolean flagRequireWriteToEeprom)
at Comfort.Form1.SetNewConfiguration(Configuration newConfiguration, Boolean keepPanel)
at Comfort.Form1.NewConfiguration(String filename)
at Comfort.Form1..ctor(String filename)
at Comfort.Program.Main(String[] arguments)



 Posted: Saturday Nov 23rd, 2013 07:15 am
   PM  Quote  Reply 
3rd Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3497
Status: 
Offline

  back to top

Did you get this exception with 3.7.6?

Can you send the cclx file to support@cytech.biz please



 Posted: Sunday Nov 24th, 2013 03:59 am
   PM  Quote  Reply 
4th Post
simond
Member
 

Joined: Saturday Jan 24th, 2009
Location: United Kingdom
Posts: 28
Status: 
Offline

  back to top

Thanks ident - I've emailed the CCLX file. Yes I twas getting it with the 3.7.6 version of Comfigurator too, but only since using heatmiser ucm...



 Posted: Friday Dec 6th, 2013 11:07 pm
   PM  Quote  Reply 
5th Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3497
Status: 
Offline

  back to top

Comfigurator 3.7.8 (Beta) can be downloaded from the website
The changes are

Known Issues
  1. when connected to KT03 USB, Comfigurator repeatedly sends f?00 message
Bug Fixes
  1. Thermostat function registers were displayed by name but not in alphabetic order
  2. Heatmiser display date format in Heatmiser module properties were missing the / separator eg 21/1113 instead of 21/11/13
  3. Execute Responses when the Response is longer than 24 bytes  asked to write to Comfort but after writing, Execute Response will still ask to write to Comfort
  4. Display of Serial Numbers for Comfort was incorrect, shows Invalid.
  5. When reading event log and Comfigurator is on the GSM4 or Zwave or Heatimiser configuration tab, the event log may get an error message "Event Log Format Invalid.. RA.."
  6. Module Scan may be interrupted by some status reports and give error message "Module Scan Timed out - Please retry later". If this occurs, just redo the Module scan
New Features
  1. Comfort Server Manager link for UCM/ETH03 is seen next to DS Manager (for UCM/ETH02)
  2. Heatmiser configurator has been improved, Read Only parameters are shown, and more parameters are supported. This requires a new version of UCM/Heatmiser 7.034
  3. UCM/GSM4 Zone Names, Alarm Names, User Names allows spaces in the names


Last edited on Friday Feb 7th, 2014 02:45 am by



 Posted: Saturday Dec 7th, 2013 03:13 am
   PM  Quote  Reply 
6th Post
simond
Member
 

Joined: Saturday Jan 24th, 2009
Location: United Kingdom
Posts: 28
Status: 
Offline

  back to top

Thanks - I've updated to 3.7.8 but am still getting the exception as above when I launch with the CCLX with my heatmiser config in...

Any view when Heatmiser 7.034 will be out and what additional parameters will be supported? Will the new parameters require a relearn and thus a remapping of all existing registers?

Cheers, Simon



 Posted: Saturday Dec 7th, 2013 03:26 am
   PM  Quote  Reply 
7th Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3497
Status: 
Offline

  back to top

We have not managed to duplicate the exception even with your cclx file
That suggests it may be a problem with one of the installed files

Try  relearning the Heatmiser. This will not erase the mappings that you have assigned

Also uninstall and reinstall your Comfigurator


You can see the changes in Heatmiser mapping in Comfigurator
The new firmware should be available for testing soon



 Posted: Wednesday Dec 11th, 2013 04:00 am
   PM  Quote  Reply 
8th Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3497
Status: 
Offline

  back to top

Comfigurator 3.7.8 is released
It fixes all bugs that have been identified so far
Please upgrade



 Posted: Monday Jan 6th, 2014 12:29 pm
   PM  Quote  Reply 
9th Post
srooks
Member
 

Joined: Tuesday Feb 26th, 2008
Location:  
Posts: 39
Status: 
Offline

  back to top

Hi,
I've just upgraded to 3.7.8. Issues I'm seeing are:
- Still getting phantom KP04 keypad if I scan for all modules
- Cannot update firmware on KT03 via network. If I right click over the module, I do not see "Check for firmware updates" and under Transfer/Firmware Upgrade I only see "By Firmware programming Cable..." no option for using UCM via network.
I have configured Comfigurator to use Network (local).

S



 Posted: Monday Jan 6th, 2014 09:06 pm
   PM  Quote  Reply 
10th Post
hendy
Cytech


Joined: Wednesday Sep 19th, 2007
Location: Singapore
Posts: 221
Status: 
Offline

  back to top

-  How many keypads are connected to your system? Is the first keypad KP04 model?

- I'm always seeing the 'Check for Firmware Updates' every time I right-click on any keypad in 3.7.8. What are the options you seeing? A screenshot will help.



 Posted: Thursday Jan 9th, 2014 09:49 pm
   PM  Quote  Reply 
11th Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3497
Status: 
Offline

  back to top

The "phantom Keypad" is produced by the following conditions
  1. The cclx file had a keypad eg KP04 in the modules tab say at ID 1
  2. Scanning of modules detects that there is a different keypad at the same ID say KT03
  3. The KP04 that was not found is not deleted from the configuration. Instead it is moved to the last (unused) ID and marked in Red as "Not found". you can now delete it manually. The reason for this is that some modules have programmed  data like KT03, UCM/KNX etc with data. If the module was temporarily removed for testing, we do not want to delete the programed data, so the module is not deleted automatically.
For Firmware upgrade, right click on the module should show the firmware upgrade options



Transfer > Firmware Upgrades is for firmware upgrade by programmng cable for firmware < version 6




 Posted: Saturday Jan 11th, 2014 03:06 am
   PM  Quote  Reply 
12th Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3497
Status: 
Offline

  back to top

Update

Right clicking on keypads will not show the options to upgrade firmware if the module after scanning is "not found" ie in red
That means the scan was unable to detect the keypad, hence it would not be possible to upgrade its firmware. The KT03 was not found perhaps because its ID was set to FF ie unassigned. Older KT03 firmware may have a problem of having the ID reset to FF
Upgrading to KT03 7.032 will probably fix this issue




Attachment: jcfhffed.png (Downloaded 42 times)



 Current time is 03:29 am
Top




UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems