Comfort Home Automation/ Security System Forums Home
Home Search search Menu menu Not logged in - Login | Register

How to Upgrade SEM Firmware
 Moderated by: ident
 New Topic   Reply   Printer Friendly 
 Rate Topic 
AuthorPost
 Posted: Friday Oct 14th, 2011 04:15 pm
   PM  Quote  Reply 
1st Post
schford
UCM Pi Users
 

Joined: Wednesday Feb 25th, 2009
Location:  
Posts: 248
Status: 
Offline

  back to top

Comfort is on latest 6x UCM Network again on latest 6x ..

New board is going in the attic so though I would be smart(hah) and upgrade it first :-)

Sticker on it says current firmware is SEM 5.139

Thought easiest way of doing it would be just to plug a 485 cable into it which I thought would give me 12v ov and the data bus.

Green light appears and then flashes.

I fire up Configurator go to modules then scan for new slave. - Get an error message "Communication Error or Comfort or UCM Firmware does not support scan"

Think to myself maybe as its such old firmware - so then I try to upgrade it from the UCM using the programmign cable but keep getting upgrade error.

So now am a bit stuck - anyone tell me how to do it?

Thanks

Stuart

Last edited on Friday Oct 14th, 2011 04:33 pm by schford



 Posted: Friday Oct 14th, 2011 04:24 pm
   PM  Quote  Reply 
2nd Post
schford
UCM Pi Users
 

Joined: Wednesday Feb 25th, 2009
Location:  
Posts: 248
Status: 
Offline

  back to top

I tried removing the 485 cable to upgrade it - it didn't work but comfort did tell me slave one had lost communications.

I am really stumped now!

Incidentally I manually added Slave 1 to comfigurator and synced and now sem green light is solid.

Last edited on Friday Oct 14th, 2011 04:27 pm by schford



 Posted: Friday Oct 14th, 2011 04:39 pm
   PM  Quote  Reply 
3rd Post
schford
UCM Pi Users
 

Joined: Wednesday Feb 25th, 2009
Location:  
Posts: 248
Status: 
Offline

  back to top

yay all done I found http://www.comfortforums.com/view_topic.php?id=1782&forum_id=4&highlight=sem+upgrade

IS it worth making a link to it from the SEM firmware forum so no one else makes an idiot of themselves like I do :-)

Last edited on Friday Oct 14th, 2011 04:44 pm by schford



 Posted: Friday Oct 14th, 2011 08:28 pm
   PM  Quote  Reply 
4th Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3497
Status: 
Offline

  back to top

You have just done the link!

To summarise, Slave and other modules with firmware less than version 6 need to be upgraded using the UCM programming cable, see http://www.comfortforums.com/view_topic.php?id=1782&forum_id=4&highlight=sem+upgrade

Once at version 6, the programming cable is not necessary, the modules can be upgraded using Comfogurator and UCM by Direct Connection if it is the UCM itself of By Comfort Bus see http://www.comfortforums.com/forum92/850.html

Last edited on Friday Oct 14th, 2011 08:33 pm by ident



 Current time is 09:08 am
Top




UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems