Comfort Home Automation/ Security System Forums Home
Home Search search Menu menu Not logged in - Login | Register

 Moderated by: ident
 New Topic   Reply   Printer Friendly 
 Rate Topic 
 Posted: Monday Aug 15th, 2011 04:57 am
   PM  Quote  Reply 
1st Post
Comfort Distributors

Joined: Wednesday Jul 12th, 2006
Location: United Kingdom
Posts: 557

  back to top

In order to "upgrade via bus" does the firmware have to already be 6.XX

e.g. If you have main board at 6.XX and a UCM at 5.XX

- are you able to upgrade the UCM to 6.XX OR do you have to manually upgrade the UCM BEFORE you can then the use the bus to go from (say) 6.0 to 6.1 ?

 Posted: Monday Aug 15th, 2011 08:44 am
   PM  Quote  Reply 
2nd Post

Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4154

  back to top

You need the modules firmware to be in place to support the Upgrading by Bus and Upgrading by direct connection.

Furthermore to upgrade a module by bus connection, even though that module is already version 6, you need a UCM at version 6 and Comfort at version 6. This is because the UCM needs to pass the information to Comfort to pass the information to the module on the bus

To make it simple we have designated the modules with the required firmware are version 6.

So to answer your question, you have Comfort at and UCM at, you need to upgrade the UCM to and this can only be done by the programming cable

Once the UCM is you can upgrade Comfort to and itself to
To test the upgrade you can upgrade 6.008 with 6.008 and Comfort 6.005 with 6.005 as you may not have another firmware with another version.

It is not going to change the firmware inside but it shows that the firmware upgrade in this way can work

 Current time is 06:30 am

UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems