Comfort Home Automation/ Security System Forums Home
Home Search search Menu menu Not logged in - Login | Register
Comfort Home Automation/ Security System Forums > Support > Firmware History > Slave Firmware > Comfort I Slave Firmware Compatibiliy with Comfort II

Comfort I Slave Firmware Compatibiliy with Comfort II
 Moderated by: ident
 New Topic   Reply   Printer Friendly 
 Rate Topic 
AuthorPost
 Posted: Monday Jan 4th, 2010 04:12 am
   PM  Quote  Reply 
1st Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4292
Status: 
Offline

  back to top

The document Slave Compatibility Table shows which Comfort I Slave firmware versions can be used with Comfort II
Note that Slave firmware 4.95 and older are not compatible with Comfort II. http://www.cytech.biz/slave_firmware_compatibility.html?category_id=99
The firmware can be upgraded to SEM 4.178 by changing the U1 IC. Please contact  support@cytech.biz about this


Last edited on Thursday Apr 14th, 2011 07:43 am by ident



 Posted: Thursday Apr 14th, 2011 07:30 am
   PM  Quote  Reply 
2nd Post
gaynorc
Member
 

Joined: Sunday Dec 31st, 2006
Location: Ireland
Posts: 130
Status: 
Offline

  back to top

The Slave Firmware Compatibility doucment link is giving me a 404 page not found error.

Where can I find it?

Thanks



 Posted: Thursday Apr 14th, 2011 07:44 am
   PM  Quote  Reply 
3rd Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3497
Status: 
Offline

  back to top

The link has been corrected in the above post
It should be Slave Firmware Compatibility



 Posted: Thursday Apr 14th, 2011 08:22 am
   PM  Quote  Reply 
4th Post
gaynorc
Member
 

Joined: Sunday Dec 31st, 2006
Location: Ireland
Posts: 130
Status: 
Offline

  back to top

Thank you



 Posted: Sunday Oct 20th, 2013 06:45 pm
   PM  Quote  Reply 
5th Post
mikegriff
Member
 

Joined: Saturday Aug 19th, 2006
Location: United Kingdom
Posts: 94
Status: 
Offline

  back to top

Hi
I have 2 slave panels running 4.177 from my old Comfort 1 system
I have one other slave which is fully uodated
Would my system work better with Upgraded slave units

I notice that recent firmware updates to the slave units migh mean that my system isn't working to full capacity
Thanks in advance
Mike

Attachment: present comfort.JPG (Downloaded 27 times)



 Posted: Monday Oct 21st, 2013 07:04 am
   PM  Quote  Reply 
6th Post
hendy
Cytech


Joined: Wednesday Sep 19th, 2007
Location: Singapore
Posts: 221
Status: 
Offline

  back to top

Old Slave 4.177 firmware can't be upgraded further.

Sorry but I do not understand the recent firmware update (to slave or Comfort?) might cause the system not to work to the full capacity?
Where did you get this info from?



 Posted: Monday Oct 21st, 2013 09:16 am
   PM  Quote  Reply 
7th Post
mikegriff
Member
 

Joined: Saturday Aug 19th, 2006
Location: United Kingdom
Posts: 94
Status: 
Offline

  back to top

Hi
Sorry I worded it wrongly
I realised I couldn't update the MK1 Slaves

What I was asking was "For how long will the Mk1 Slaves work?"
I was asking because when you update the firmware on mk 2 Slaves for instance
The changes in SEM 6.068 are

4. RS485 Receive buffer size from 127 to 240 bytes

This must have been done for a reason and is something which cant be done on the MK1 Boards

Mike



 Posted: Tuesday Oct 22nd, 2013 02:49 am
   PM  Quote  Reply 
8th Post
hendy
Cytech


Joined: Wednesday Sep 19th, 2007
Location: Singapore
Posts: 221
Status: 
Offline

  back to top

"For how long will the Mk1 Slaves work?"

I think this is more of the question of hardware rather than firmware.
Slave 4.177 is an old one, around 8 years back, so for how long it will continue to work I'd say that it shall work as long as all the components/parts continue to work fine.

As for the increase in buffer size in the new firmware, this is probably to cater for the newer feature introduced in Comfort.
I'm not really sure exactly what the new feature is but this would simply mean that your old Slave I will not be able to make use of the new feature (if any).
The basic function of slave i.e. reporting of zones status should not be affected though.



 Posted: Tuesday Oct 22nd, 2013 09:04 pm
   PM  Quote  Reply 
9th Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3497
Status: 
Offline

  back to top

Yes, the increase in message buffer size in Comfort should be to cater for features like Firmware upgrading which do not apply to Slaves anyway, so the version 1 slaves should continue to function as long as it does not develop any faults



 Current time is 01:05 am
Comfort Home Automation/ Security System Forums > Support > Firmware History > Slave Firmware > Comfort I Slave Firmware Compatibiliy with Comfort II
Top




UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems