Comfort Home Automation/ Security System Forums Home
Home Search search Menu menu Not logged in - Login | Register

Problems upgradign Vocab
 Moderated by: slychiu
 New Topic   Reply   Printer Friendly 
 Rate Topic 
AuthorPost
 Posted: Saturday Aug 13th, 2016 12:28 pm
   PM  Quote  Reply 
1st Post
cc_uk
Member
 

Joined: Friday Mar 28th, 2014
Location:  
Posts: 63
Status: 
Offline

  back to top

I am trying to update my Comfort II system with the kate39.bin Vocab file following upgrade to the 7.112 beta firmware to support partitions.

The Firmware upgrade to 7.112 went well.     My ETh03 & UCM are already ont he latest firmware, and I am using Comfigurator 3.11.6.0

When I try to upload the Kate39.bin file I get The upgrading Vocabulary dialogue box appear but it never progresses.  The KP04A keypad displays Keypad not polled for a while, and eventually I get Vocabulary upgrade incomplete, Please try Vocabulary Upgrade again. 

After that Comfort resets and I get WRONG TEXT PUSH *1 together on the keypad.

Comfigurator then reports the vocabulary version as 255

Any help appreciated.



 Posted: Saturday Aug 13th, 2016 02:13 pm
   PM  Quote  Reply 
2nd Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4099
Status: 
Offline

  back to top

You are right
There seems to bee a problem with upgrading vocabulary
Please hold on. I will see if downgrading the firmware wil allow the vocab upgrade to work. The firmware 7.112 has been removed for now until we figure ut what is the priblem



 Posted: Saturday Aug 13th, 2016 02:20 pm
   PM  Quote  Reply 
3rd Post
cc_uk
Member
 

Joined: Friday Mar 28th, 2014
Location:  
Posts: 63
Status: 
Offline

  back to top

Hi I have just tried downgrading the firmware and find that does allow recovery and upgrading of the vocabulary.

The system is working correctly now. I left Comfigurator at 3.11.6.0 so it was just the comfort firmware I downgraded to try this



 Posted: Saturday Aug 13th, 2016 02:23 pm
   PM  Quote  Reply 
4th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4099
Status: 
Offline

  back to top

Thnaks for the confrm. My firmware downgrade us still goung on



 Posted: Saturday Aug 13th, 2016 03:27 pm
   PM  Quote  Reply 
5th Post
juwi_uk
Advanced Member


Joined: Friday May 25th, 2007
Location: Newbury, United Kingdom
Posts: 1240
Status: 
Offline

  back to top

I'm just downgrading to 7.107 to try again.   Strangely the Sentence tables did upgrade OK in 7.112 but the progress bar never shows any sign of movement for the full vocab upgrade (up to point when it aborts).



 Posted: Saturday Aug 13th, 2016 03:38 pm
   PM  Quote  Reply 
6th Post
cc_uk
Member
 

Joined: Friday Mar 28th, 2014
Location:  
Posts: 63
Status: 
Offline

  back to top

Same result for me. I could upgrade the sentence tables and LCD text

This fixed the LCD text but left no voice

After the firmware downgrade I was able to repeat and get the voice working



 Posted: Saturday Aug 13th, 2016 03:59 pm
   PM  Quote  Reply 
7th Post
juwi_uk
Advanced Member


Joined: Friday May 25th, 2007
Location: Newbury, United Kingdom
Posts: 1240
Status: 
Offline

  back to top

My Vocab now upgraded OK.

When i try to write CCLX to Comfort I now get this; any ideas?

Ju

 

 

Attachment: vocab.jpg (Downloaded 34 times)



 Posted: Sunday Aug 14th, 2016 02:25 am
   PM  Quote  Reply 
8th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4099
Status: 
Offline

  back to top

It means the vocab setting in Comfigurator is different from the vicab in Comfort (that you upgraded)

Configuration > Modules and Settings shows the Vocab in Configurator eg English Residential

Configuration > System Information shpws the vocan in Comforrt




 Posted: Sunday Aug 14th, 2016 04:15 am
   PM  Quote  Reply 
9th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4099
Status: 
Offline

  back to top

The vocab upgrade problem has been fixed. It will be in ULT 7.113
We will do more testing before the beta.
Apologies for the bug as the firmware has very major changes and the vocab bug was missed out



 Posted: Sunday Aug 14th, 2016 07:23 am
   PM  Quote  Reply 
10th Post
juwi_uk
Advanced Member


Joined: Friday May 25th, 2007
Location: Newbury, United Kingdom
Posts: 1240
Status: 
Offline

  back to top

OK but what do I do to fix and get them in sync again; I upgraded the Vocab to Myma39.bin BTW?

Configuration > Modules and Settings shows the Vocab in Configurator 

  shows "English Residential"  <-- dropdown list doesnt show myma39!

Configuration > System Information

  shows  Vocab = 5

  Custom Vocab = No

  System Vocab Ver = 39

  User Vocab Ver = 1



 Posted: Sunday Aug 14th, 2016 07:57 am
   PM  Quote  Reply 
11th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4099
Status: 
Offline

  back to top

Thats correct

Configuration > Modules and Settings shows  "English Residential" 

English Residential means english language and residential vocabulary. It applies to myma and kate.

Just do a write to comfort if there is any message about mismatch



 Posted: Sunday Aug 14th, 2016 08:38 am
   PM  Quote  Reply 
12th Post
juwi_uk
Advanced Member


Joined: Friday May 25th, 2007
Location: Newbury, United Kingdom
Posts: 1240
Status: 
Offline

  back to top

Thanks.

Interestingly enough I only got that message while trying to write to Comfort in the same Comfigurator session immediately after i'd upgraded the vocab.  Having exited Comfigurator after the error, now when I reopen the CCLX and write to comfort I dont get the same message anyway so maybe sorted itself out. 



 Posted: Sunday Aug 14th, 2016 08:46 am
   PM  Quote  Reply 
13th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4099
Status: 
Offline

  back to top

I think Comfigurator did not update the vocab in system information imedately after upgrading the vocab



 Posted: Sunday Aug 14th, 2016 12:28 pm
   PM  Quote  Reply 
14th Post
Ingo
Advanced Member


Joined: Sunday Jan 21st, 2007
Location: South Africa
Posts: 541
Status: 
Offline

  back to top

I did Myma39 before I upgraded to the latest Beta.



 Posted: Sunday Aug 14th, 2016 07:47 pm
   PM  Quote  Reply 
15th Post
juwi_uk
Advanced Member


Joined: Friday May 25th, 2007
Location: Newbury, United Kingdom
Posts: 1240
Status: 
Offline

  back to top

Having upgraded my test system OK i decided i'd follow the same with my LIVE system to get the vocab updated to myma39 as well after downgrading to ULT 7.107.  Big mistake.

The full full vocab upload completed OK and asked me to reset the system;  i did that and now the system is trashed.  Cant log on anymore via the UCM/Eth3 AND both keypads are stuck in an endless loop of trying to update their LCD text and getting to about 95% and resetting (all LEDS come on) and after a beep they start again in vicious cycle.

Had to shut the system down for the night to ponder how to get out of this hole.

Any ideas? In the meantime I'll crack open a bottle of red and drown my sorrows!

Julian

 

 

Last edited on Sunday Aug 14th, 2016 07:47 pm by juwi_uk



 Posted: Tuesday Aug 16th, 2016 04:30 am
   PM  Quote  Reply 
16th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4099
Status: 
Offline

  back to top

The vocabulary upgrade problem in 7.112 (Beta) has been fixed in ULT 7.113 (Beta)
If you have 7.112 please upgrade



 Current time is 06:03 am
Top




UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems