Comfort Home Automation/ Security System Forums Home
Home Search search Menu menu Not logged in - Login | Register

Lost single button arming
 Moderated by: admin
 New Topic   Reply   Printer Friendly 
 Rate Topic 
AuthorPost
 Posted: Sunday Nov 28th, 2010 06:06 pm
   PM  Quote  Reply 
1st Post
ianh100
Member
 

Joined: Friday Jan 26th, 2007
Location: United Kingdom
Posts: 20
Status: 
Offline

  back to top

Hi, I recently rebuilt the PC I use to manage my comfort system ( Comfort 1 Ultra). I installed the new version of comfigurator (3.2.4.0) and opened my old config file. I made just once change to a response and downloaded all of the settings.

I can't now set the alarm to away mode with the single button that I used previously I have to type in my user code and press 1 to arm. I can't seem to find a setting to correct this but assume there is just a tick box in comfigurator. Where is it?

 

Many Thanks



 Posted: Monday Nov 29th, 2010 01:33 am
   PM  Quote  Reply 
2nd Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4341
Status: 
Offline

  back to top

In Control > Keypad Look for the Away Key, assign the Response "KeyArmAwayFrom SecurityOff" and uncheck the Need Code Box as shown in the screenshot

This programs the AWAY key to arm to Away mode and not require a code

Your old file (presumably in Comfigurator 2) should have been converted to cclx for Comfigurator 3. If the file conversion was not correct somehow, please send your old file to support@cytech.biz so we can examine

Attachment: Keypad arm.jpg (Downloaded 29 times)



 Posted: Monday Nov 29th, 2010 08:07 am
   PM  Quote  Reply 
3rd Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4341
Status: 
Offline

  back to top

We have seen your config file, thanks

The Key Arm Responses in the file are wrong
eg in your file

KeyArmAwayFromSecurityOff
GetParameterValue SecurityMode
If SecurityMode = SecurityOff Then
    Exit Response
End If
KeyswitchArm AwayMode
End


The correct Response which can be examined in a default template should be
KeyArmAwayFromSecurityOff
If SecurityMode = SecurityOff Then
    KeyswitchArm AwayMode
End If
End

You can see the difference in logic between the two and why the first one would not work

This problem may have been caused by conversion to an earlier version of Comfigurator 3 which has been fixed



 Posted: Tuesday Nov 15th, 2011 01:02 pm
   PM  Quote  Reply 
4th Post
Howser
Member
 

Joined: Monday May 22nd, 2006
Location: Pretoria, South Africa
Posts: 196
Status: 
Offline

  back to top

Using Comfigurator V3.3.3.0, I created a new project and did a transfer Read (Comfort -> PC) from Comfort I Ultra. The project had the same Response logic issues as above for the Away and Night mode.



 Posted: Tuesday Nov 15th, 2011 01:21 pm
   PM  Quote  Reply 
5th Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3496
Status: 
Offline

  back to top

If you do a Read from Comfort you will overwrite the file you have on Comfigurator so it does not matter what project you have created

The config in Comfort may have been created using a very old version of Comfigurator which may have been corrupted Once you fix the  Response and write back to Comfort that should fix it



 Posted: Tuesday Nov 15th, 2011 02:49 pm
   PM  Quote  Reply 
6th Post
Howser
Member
 

Joined: Monday May 22nd, 2006
Location: Pretoria, South Africa
Posts: 196
Status: 
Offline

  back to top

Yes, I used an empty project to import the Comfort project into. Got an error prompt "Communication Error or Comfort or UCM firmware does not support scan" (attached) about 4 times in the process, but Comfigurator reported that the project was imported. I am using UCM/USM Version 6.008.

Attachment: Comfort Error.jpg (Downloaded 20 times)

Last edited on Tuesday Nov 15th, 2011 02:50 pm by Howser



 Posted: Wednesday Nov 16th, 2011 08:14 am
   PM  Quote  Reply 
7th Post
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3496
Status: 
Offline

  back to top

You may get this message if some of the modules firmware are too old (ie before (5.178) and do not suppprt the scan function
Check the Modules Tab after scanning.

Many of the modules firmware can be upgraded using the UCM programming cable



 Current time is 02:05 am
Top




UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems