Comfort Home Automation/ Security System Forums Home
Home Search search Menu menu Not logged in - Login | Register

Why so many KP problems??
 Moderated by: admin
 New Topic   Reply   Printer Friendly 
 Rate Topic 
AuthorPost
 Posted: Saturday Dec 26th, 2015 02:37 pm
   PM  Quote  Reply 
1st Post
Pgordon
Member
 

Joined: Saturday Sep 23rd, 2006
Location: London, United Kingdom
Posts: 222
Status: 
Offline

  back to top

I've been putting up with this for quite a while, but it is becoming a bit irritating now,

I seem to be having many reliability issues with my keypads...

I have 3 installed keypads, a KP06 and 2 KP04's

the KP06 is *still* losing the LCD display text on a regular and frequent basis. I am doing a keypad reset every hour (via the hourly response) and yet I still get occasions when the LCD is just blank because it has done this sometime between those resets

Now I am also noting with quite annoying frequency that all 3 of my keypads, at totally random intervals, and not necessarily at the same time as each other, will say:

"Wrong text, press * and 1 to update"

which I do, it downloads fine, and all is well..

...until the next keypad does the same, or the same keypad will do the exact same thing a few days later. With 3 keypads all doing this I'm having to deal with this issue on an almost daily basis.

What is going on??

TIA

Paul G.

 



 Posted: Saturday Dec 26th, 2015 09:22 pm
   PM  Quote  Reply 
2nd Post
Vangelis
Member
 

Joined: Tuesday Jan 31st, 2012
Location:  
Posts: 138
Status: 
Offline

  back to top

Who installed your system?

Have you done any fault finding?

If you have frequent failures on the keypad and you don't mind some wiring, I would remove the wiring from the two furthest keypads (at the Comfort Panel) leaving just one allowing control. Check stability and re-introduce them if stable.

If you still have faults the remove all keypads and run a short piece of screened cat5 from the panel direct into the keypad and check stability. This will rule out wiring to the keypads along with interference being introduced on the cable runs (possibly corrupting the keypad bus)

This obviously needs to be done at a convenient time when you are able to have some 'security down time'

Edit: You will also need to tell Comfigurator that you are removing keypads by rescanning the keypads

Vangelis

Last edited on Saturday Dec 26th, 2015 09:23 pm by Vangelis



 Posted: Sunday Dec 27th, 2015 01:56 am
   PM  Quote  Reply 
3rd Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4099
Status: 
Offline

  back to top

This is a mystery as we have not encountered multiple keypads requiring text update frequently. If you reset the keypads do they go to normal ?



 Posted: Sunday Dec 27th, 2015 10:53 am
   PM  Quote  Reply 
4th Post
Pgordon
Member
 

Joined: Saturday Sep 23rd, 2006
Location: London, United Kingdom
Posts: 222
Status: 
Offline

  back to top

Various questions, not necessarily in order...
Yes, I believe that if I do a keypad reset, all is well, and the wrong text message disappears... This is based on the behaviour of the kp06, because as I said, I do a keypad reset on that one every hour because of the other longer standing problem of the lcd going blank...

I installed the system myself. It comprises 1 main panel and 2 SEP's.

I know the wiring to all the keypads therefore... :-)

The first one installed was the kp06, it is approx 3 metres from the main panel, but with the cable route going as it does, it's approx 5-6 metres of cable. This is high quality foil screened cable.

The 2 kp04's are connected off the 2 SEP's one kp per each SEP. I have 6 core cable between the panels connecting - as per the documentation, KA,KB,COM, (not 12v+, as that is generated locally) I also carry voice & mic between panels, so I can support keypads off any panel..
That uses 5 of the available 6 cores, so the 'spare' one I have used to double up the voice line to try to minimise loss of voice quality over the cable runs.



 Posted: Sunday Dec 27th, 2015 11:39 am
   PM  Quote  Reply 
5th Post
Ingo
Advanced Member


Joined: Sunday Jan 21st, 2007
Location: South Africa
Posts: 541
Status: 
Offline

  back to top

Isn't a 'wrong text' message associated with a vocabulary update or something? My first guess would be that the KP is not getting the right 'stuff' from Comfort. That said, it should probably only check the Comfort vocabulary on startup, or every time you reset the KP.

Here is my suggestion: Make sure you have the latest vocabulary files loaded and then do a v? to know what the reply is. Then when the KPs go out-of-whack, do the same and see if it's still the same.

This is all speculation so might not amount to anything except having the latest girly voice on your system :-)

Myma38 looks to be the latest. I would also run a Bus Monitor to see if something is happening to the KPs. Filter one KP ID and see if anything is logged when the trouble starts. You might also have a noisy KA/KB line somewhere, the Bus Monitor will show errors if that is the case.

Ingo



 Posted: Sunday Dec 27th, 2015 06:03 pm
   PM  Quote  Reply 
6th Post
juwi_uk
Advanced Member


Joined: Friday May 25th, 2007
Location: Newbury, United Kingdom
Posts: 1240
Status: 
Offline

  back to top

Screened cable runs to the keypad?



 Posted: Monday Dec 28th, 2015 12:28 am
   PM  Quote  Reply 
7th Post
Swiss-Toni
Member


Joined: Thursday Sep 15th, 2011
Location: Greater London, United Kingdom
Posts: 195
Status: 
Offline

  back to top

Although it maybe screened cable, if it does come into any contact with 230V (when I say conact I am refering to side by side or criss crossing) you maybe getting EMF fields corupting the signal......



 Posted: Monday Dec 28th, 2015 04:04 am
   PM  Quote  Reply 
8th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4099
Status: 
Offline

  back to top

Yes as Ingo said Bus monitor would be a good way to check the problem

You can filter the keypads 41, 42, 43 and 00 (broadcast)
If it happens every day it should not take long to capture



For  KP04, automatic text download started from firmware version 1.019 ie it wil automatically get the text from Comfort without *1. For KP06, auto text download implemented from v6.004 onwards.



 Current time is 04:22 pm
Top




UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems