Comfort Home Automation/ Security System Forums Home
Home Search search Menu menu Not logged in - Login | Register

Error including UCM/Z-Wave in Vera Edge Network
 Moderated by: slychiu
 New Topic   Reply   Printer Friendly 
 Rate Topic 
AuthorPost
 Posted: Tuesday Jan 26th, 2016 07:21 pm
   PM  Quote  Reply 
1st Post
AdrianL
Member
 

Joined: Friday May 2nd, 2008
Location: West Sussex, UK
Posts: 64
Status: 
Offline

  back to top

I have set up a simple Z-Wave network with a Vera Edge controller. I have included the UCM/Z-Wave in the network. Comfigurator knows all the Z-Wave nodes and I can use Comfort responses to control the Z-Wave actuators and having associated flags with the nodes, Comfort knows the status of the actuators when they are changed by Comfort or by Z-Wave nodes.

In other words, everything seems to be working as expected except the Vera Edge has "Error: unable to get any information on node" against the UCM/Z-Wave node. Vera Edge seems to think the UCM/Z-Wave is a "SceneController1". Repeating the learn process for the UCM/Z-Wave doesn't make any difference.

I suppose as it all works I shouldn't worry but clearly something is not quite right with the setup which may cause problems in the future. Anybody any ideas?



 Posted: Tuesday Jan 26th, 2016 09:52 pm
   PM  Quote  Reply 
2nd Post
Vangelis
Member
 

Joined: Tuesday Jan 31st, 2012
Location:  
Posts: 138
Status: 
Offline

  back to top

My understanding is that there can only be one ZWave Master. This will normally be Comfort (in order to gain status of ZWave nodes)

In your case you have Vera as the Master and Comfort as a node (which I don't think it will work) and therefore will not ident correctly to Vera

Vangelis...



 Posted: Tuesday Jan 26th, 2016 11:01 pm
   PM  Quote  Reply 
3rd Post
juwi_uk
Member


Joined: Friday May 25th, 2007
Location: Newbury, United Kingdom
Posts: 1254
Status: 
Offline

  back to top

Adrian has it correct; the Comfort Zwave UCM always is the secondary controller.
My first primary controller was an ACT Homepro, then i upgraded to a Remotec ZRC100 and now finally settled on the Fibaro Home Center 2 (did that as most of my units are Fibaro anyway)
I hear Vera is good too as well.
Julian



 Posted: Wednesday Jan 27th, 2016 07:58 am
   PM  Quote  Reply 
4th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4853
Status: 
Offline

  back to top

UCM/Zwave is a secondary controller. Have you tried adding another secondary controller using Vera Edge?



 Posted: Wednesday Jan 27th, 2016 04:27 pm
   PM  Quote  Reply 
5th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4853
Status: 
Offline

  back to top

Another user who has Vera Edge verifies that he also has the message. But otherwise there should be no problem. Vera thinks UCM/zwave is a scene controller for some rason



 Posted: Wednesday Jan 27th, 2016 07:18 pm
   PM  Quote  Reply 
6th Post
Vangelis
Member
 

Joined: Tuesday Jan 31st, 2012
Location:  
Posts: 138
Status: 
Offline

  back to top

Sorry for any confusion :) This is why I don't use my ZWave/UCM....(never could get it to do what i wanted)

Vangelis



 Posted: Wednesday Jan 27th, 2016 09:37 pm
   PM  Quote  Reply 
7th Post
AdrianL
Member
 

Joined: Friday May 2nd, 2008
Location: West Sussex, UK
Posts: 64
Status: 
Offline

  back to top

Yes I have a Popp Wall Controller included in the Z-Wave network and Vera is quite happy with that. I have also added a Comfort Virtual Node and again it all seems to be working fine (I can trigger Comfort responses with Z-Wave sensors) but have the same error message against the virtual node in Vera. Looking at the log, Vera is sending a "reconfigure" action which the UCM/Z-Wave ignores. (At least I think that's what's happening - the log is quite difficult to interpret without a detailed knowledge of Z-Wave protocols! )



 Posted: Saturday Jan 30th, 2016 12:50 pm
   PM  Quote  Reply 
8th Post
juwi_uk
Member


Joined: Friday May 25th, 2007
Location: Newbury, United Kingdom
Posts: 1254
Status: 
Offline

  back to top

IMHO it would be nice to beef up the UCM/Zwave:

  • Z-WavePLUS (ie dev a new v4 new daughter card)
  • Support the secure classes for inclusion
  • lobby the major primary controller companies so that the Comfort/UCM is recognised as a "known" secondary controller; and thus maybe a bit better supported.  I'm sure the list is longer but ones like Vera Edge and Fibaro Home Center 2 are two we all seem to use on this community as a start. For example I use Fibaro and they still haven't created a "template" for the UCM even though plenty of other templates for devices are getting created.
I know Cytech resources aren't infinite and I'm sure you want to interface to as many devices as possible so that you maximise your sales activities,  I also think that maybe a few of these integrations like CBUS and ZWave should have "premium" developer status and maybe have features that go a tad further than some of the other "first gen" integrations.

Personally I want a reliable retrofit solution and hoped Zwave was it,  but I'm sure others want a new build solution and if Comfort could "really..really" (that's technical for more features!) support these then life would be sweet!

In terms of my UCM/ZWave3 I sort of agree with Vangelis, I don't really use mine much either now.

:)

 

 



 Posted: Thursday May 2nd, 2019 07:08 pm
   PM  Quote  Reply 
9th Post
bmistry3
Member
 

Joined: Sunday Mar 17th, 2019
Location:  
Posts: 4
Status: 
Offline

  back to top

I just added a Vera Edge, I selected generic device from the Vera Edge U17 screen. I also get the same message mentioned in this post and also Vera thinks the UCM/ZWave is a scene controller.
Is generic device the right device to select to add the UCM/ZWave
I have not tested yet but will try over weekend



 Posted: Monday May 6th, 2019 02:22 pm
   PM  Quote  Reply 
10th Post
bmistry3
Member
 

Joined: Sunday Mar 17th, 2019
Location:  
Posts: 4
Status: 
Offline

  back to top

Chiu / Forum members - Please help..

As per my previous post, I have a Vera Edge setup with Fibaro Dimmer and Fibaro Motion sensor. I also have Philips Hue plug-in in Vera U17 software.

All this works fine on Vera U17, motion sensor detects motion and temp, The dimmer module can be controlled from Vera U17. I can switch on/off lights and dim the lights. I can setup scenes in Vera U17 and on detecting motion it can switch dimmer 2 module or the Philips Hue lights.

I am struggling with UCM Zwave. I have it installed in my comfort 2, no errors (See pictures of module properties and mapping). My Vera Edge U17 see's it a a scene controller but I get "unable to get information from node" in the Vera U17 software.

In comfort, the Fibaro sensor appears as a Slave_Garage_Door and the Fibaro dimmer as Slave_Multichannel.

When I try the "On" & "Off" function it does not work, the lights do not come on when executed from Comfort.

Please can someone help me
Bhupendra

Attachment: UCMZave Mapping.PNG (Downloaded 12 times)

Last edited on Monday May 6th, 2019 02:24 pm by bmistry3



 Current time is 04:41 am
Top




UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems