Comfort Home Automation/ Security System Forums Home
Home Search search Menu menu Not logged in - Login | Register

How many UCMs do I need?
 Moderated by: slychiu
 New Topic   Reply   Printer Friendly 
 Rate Topic 
AuthorPost
 Posted: Friday Oct 23rd, 2009 05:51 pm
   PM  Quote  Reply 
1st Post
gsnottingham
Member
 

Joined: Tuesday Nov 13th, 2007
Location: United Kingdom
Posts: 32
Status: 
Offline

  back to top

My current system is Ultra 5.115 and I have one UCM01/ethernet running 5.092 which I use to program comfort via ethernet. So far as I am aware, I do not use the UCM01 for anything else.

I would like to be able to update the main comfort firmware and I understand that I will need to buy a UCM05 in order to do this.

Will I be able to upgrade the main comfort firmware using the new UCM05 via my existing UCM01/ethernet? If not, will I be able to upgrade it via ethernet if I buy the optional ethernet module to plug into the UCM05?

I know that in order to update the firmware on the UCM05 itself I would need to have a second UCM05 - but do I need to be able to do this? If my only use for the UCM05 is as a tool to upgrade the main ultra firmware it is unclear whether the various improvements to the UCM firmware listed in the history sections of this forum are relevant to me.

Many thanks for any help; please forgive me if the question is too stupid or answered very clearly elsewhere (in which case I have not been able to find it).

Graham



 Posted: Friday Oct 23rd, 2009 07:00 pm
   PM  Quote  Reply 
2nd Post
juwi_uk
Member


Joined: Friday May 25th, 2007
Location: Newbury, United Kingdom
Posts: 1246
Status: 
Offline

  back to top

Hi

I expect Cytech will give you the definitive on this but I went through a similar upgrade path.

I purchased a new UCM05 and swapped the Eth01 module from the old UCM to the UCM05 instead and all was fine.

But it didnt end there as I discovered (this is in a thread somewhere else in this forum) that my old UCM01/Ethernet was in fact an early UCM05 in disguise and had a flash firmware so I could use this to upgrade the UCM's respectively as new firmwares come out.  Cant say whether your old UCM is like this too but it's worth checking.  I think if you have the PP1 and PP3 headers then that's what identified mine.

Regards

Julian

 



 Posted: Saturday Oct 24th, 2009 02:04 am
   PM  Quote  Reply 
3rd Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4341
Status: 
Offline

  back to top

Unfortunately your UCM is UCM01 which is not able to upgrade Comfort firmware. The UCM05 shown below has the 6 way and 2 way programming connectors PP1 and PP3 for the programming cable to connect to the device being programmed

Julians UCM/Ethernet was an Eth01 on top of a UCM05 while yours is an Eth01 on top of a UCM01

It is worthwhile to change to a UCM05. Besides allowing you to upgrade Comfort, Slave, and other UCM firmware, the uploading and downloading speed is much faster than for the UCM01

We have firrmware upgrare packages for Comfort II, UCM, and keypad see http://www.comfortforums.com/forum25/1403.html which many Comfort I users have already taken advantage of

I believe a UCM01 to UCM05 upgrade would be useful, and we may introduce this


Attachment: ucm05_small.jpg (Downloaded 44 times)



 Posted: Saturday Oct 24th, 2009 02:08 am
   PM  Quote  Reply 
4th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4341
Status: 
Offline

  back to top

I forgot to say the we now have a UCM/USB which allows you to connect via USB instead of the Rs232 serial port which can hardly be found on computers nowadays

Attachment: UCM_USB small.jpg (Downloaded 43 times)



 Current time is 08:27 am
Top




UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems